Bug 169379 - Kernek oops on USB storage device removal
Kernek oops on USB storage device removal
Status: CLOSED DUPLICATE of bug 168616
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 14:22 EDT by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 15:44:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2005-09-27 14:22:02 EDT
Description of problem:
The kernel throws an oops when removing a usb storage device. The device was not
mounted or otherwise used, apart from the autodetection routines for hotplug and
udev.

Kernel messages on insert:
usb 1-1: new full speed USB device using ohci_hcd and address 2
SCSI subsystem initialized
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
  Vendor: Generic   Model: USB Flash Drive   Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
usb-storage: device scan complete
SCSI device sda: 128512 512-byte hdwr sectors (66 MB)
sda: Write Protect is on
sda: Mode Sense: 0b 00 80 08
sda: assuming drive cache: write through
SCSI device sda: 128512 512-byte hdwr sectors (66 MB)
sda: Write Protect is on
sda: Mode Sense: 0b 00 80 08
assuming drive cache: write through
 sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0

The device is removed after some seconds:
usb 1-1: USB disconnect, address 2
Oops: kernel access of bad area, sig: 11 [#1]
NIP: D9D9D6C0 LR: D9D9D6B8 SP: D7EA7DD0 REGS: d7ea7d20 TRAP: 0600    Not tainted
MSR: 00009032 EE: 1 PR: 0 FP: 0 ME: 1 IR/DR: 11
DAR: 6B6B6BB3, DSISR: 00000000
TASK = d7f16c30[25] 'khubd' THREAD: d7ea6000
Last syscall: -1
GPR00: D9D9D6B8 D7EA7DD0 D7F16C30 6B6B6BB3 C011CF50 00000000 D33C9668 FFFFFFFF
GPR08: 00052C00 00000000 C04429D4 C01A6AF0 22808022 00000000 D7CC73CC 00000000
GPR16: C0AEA8A4 C1B5E8F4 00000000 C035C228 00000003 C0360000 00000100 00000001
GPR24: D7CC73C4 C0AEA88C C0AEA8A4 C1B5EB84 D253B044 D253B08C D253B03C D33C926C
NIP [d9d9d6c0] scsi_remove_device+0x60/0xc0 [scsi_mod]
LR [d9d9d6b8] scsi_remove_device+0x58/0xc0 [scsi_mod]
Call trace:
 [d9d9dac4] __scsi_remove_target+0xd4/0x130 [scsi_mod]
 [d9d9a844] scsi_forget_host+0x54/0xa0 [scsi_mod]
 [d9d9316c] scsi_remove_host+0x7c/0xf0 [scsi_mod]
 [d9d22dcc] quiesce_and_remove_host+0xec/0x140 [usb_storage]
 [d9d22e48] storage_disconnect+0x28/0x40 [usb_storage]
 [c0211c94] usb_unbind_interface+0x54/0x90
 [c01a8dbc] __device_release_driver+0x6c/0x90
 [c01a92b0] device_release_driver+0x50/0xb0
 [c01a86c0] bus_remove_device+0xa0/0xd0
 [c01a6e88] device_del+0x58/0xc0
 [c0218d64] usb_disable_device+0x114/0x1b0
 [c0212504] usb_disconnect+0xd4/0x1f0
 [c0214f48] hub_thread+0x2c8/0xda0
 [c0038238] kthread+0x108/0x110
 [c00077cc] kernel_thread+0x44/0x60

After this, khubd is dead and USB is nonfunctional.
An USB-Serial-Converter does not trigger this.
The storage device works fine with earlier kernels
on the same machine.

Version-Release number of selected component (if applicable):
2.6.13-1.1578_FC5

How reproducible:
Always


Steps to Reproduce:
1. Insert USB storage media
2. wait some seconds
3. remove media
  
Actual results:
Kernel oops, USB dies


Expected results:
normal remove

Additional info:
Comment 1 Pete Zaitcev 2005-09-27 15:44:52 EDT

*** This bug has been marked as a duplicate of 168616 ***

Note You need to log in before you can comment on or make changes to this bug.