Bug 169380 - Error inserting w83627ehf
Error inserting w83627ehf
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 14:29 EDT by tony
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 17:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tony 2005-09-27 14:29:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
"modprobe w83627ehf" produces an error
FATAL: Error inserting w83627ehf (/lib/modules/2.6.13-1.1524_FC4smp/kernel/drivers/hwmon/w83627ehf.ko): No such device
The device is not loaded. According to lm_sensors website (http://secure.netroedge.com) support for w83627ehf began in 2.6.13-rc1

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1524_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. Type modprobe w83627ehf
2.
3.
  

Actual Results:  Error message; device not loaded

Expected Results:  Driver loaded

Additional info:
Comment 1 Dave Jones 2005-09-30 02:26:34 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 2 Dave Jones 2005-09-30 06:00:04 EDT
also, are you sure this is the right chip driver for your system ?
Comment 3 tony 2005-09-30 10:42:39 EDT
I tried the 2.6.13-1.1526_FC4smp kernel, but with the same result.

I am using a S'micro PDSMi board; I should have mentioned that before. According
to their website it uses the Winbond 83627EHF chip.

I notice that the winbond chip does not show up in the boot logs or the
/etc/sysconfig/hwconf file, but neither do similar devices on other boxes (for
example w83781d) which load fine on a modprobe.

I thought the w83627hf driver might be close enough, but alas no. It loads on
modprobe and runs lm_sensors but the output is nonsense.
Comment 4 tony 2005-10-03 15:28:15 EDT
It seems the S'micro web site information is wrong. Looking in the box its
apparently a W83627HF chip. This doesnt answer the question as to why the
voltages and temperatures are reported incorrectly, but its not a kernel bug.

Sorry to waste your time

Tony

Note You need to log in before you can comment on or make changes to this bug.