Bug 169384 - gam_server leaks
gam_server leaks
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 14:50 EDT by Pete Zaitcev
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 19:28:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2005-09-27 14:50:54 EDT
Description of problem:

zaitcev   3413 26.7 44.9  88980 85880 ?        S    01:41 214:43
/usr/libexec/gam_server

Version-Release number of selected component (if applicable):

gamin-0.1.6-1

How reproducible:

Not on every computer. But where it happens, killing gam_server
does not solve the problem.

Steps to Reproduce:
1. Watch RSS

Actual results:

System runs out of memory.

Expected results:

System does not run out of memory.

Additional info:
Comment 1 Pete Zaitcev 2005-09-27 14:52:35 EDT
Curiously enough, 0.1.6-1 changelog says "memory leak fix".
If anything it made things far worse than before.
Trying 0.1.6-3 now...
Comment 2 Daniel Veillard 2005-09-27 17:24:26 EDT
I don't see how adding calls to free() can increase memory leaks.
I can't reproduce it, if you do, valgrind 3.0.1 on gam_server
should allow to show said leaks.
Comment 3 Pete Zaitcev 2005-09-27 19:28:40 EDT
Running under valgrind makes gam_server to exit, and it won't keep running now.

I think that perhaps something had an earlier version of libgamin-1.so*.
This is all done without logging out.
Comment 4 Daniel Veillard 2005-09-28 04:05:32 EDT
only on per user gam_server can run at a given time so if you start
a new one under valgrind it will exit immediately, not valgrind related
unless you have a valgrind older than 3.01

http://www.gnome.org/~veillard/gamin/debug.html#Debugging1
gives informations on how to find what is using gamin and how it is using it

I don't understand what you mean by
 "I think that perhaps something had an earlier version of libgamin-1.so*.
  This is all done without logging out."
Does this mean that if you log out and in again you don't see the problem ?

Daniel
Comment 5 Pete Zaitcev 2005-09-28 21:56:47 EDT
Yes, it seems all right now. No problem.
Comment 6 Daniel Veillard 2005-09-29 05:22:27 EDT
okay, thanks !

Daniel

Note You need to log in before you can comment on or make changes to this bug.