Bug 1693840 - Packages API not emitting correct list metadata
Summary: Packages API not emitting correct list metadata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: ---
: 4.1.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On: 1694525
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-28 18:52 UTC by Evan Cordell
Modified: 2019-06-04 10:46 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:37 UTC

Description Evan Cordell 2019-03-28 18:52:41 UTC
Description of problem:

The packages api updated to support the old and new api versions and group. After that change, the `list` operation on packages stopped emitting correct list metadata. Kubectl ignores this problem and displays correctly, but console breaks without this meatadata in place. The symptom is that no UI for operatorhub is displayed in the cluster.


How reproducible:
always


Steps to Reproduce:
1. Go to OperatorHub UI


Actual results:

No packages visible

Expected results:

See operator packages


Additional info:

Comment 2 Evan Cordell 2019-03-28 23:25:35 UTC
Fix is merged.

Comment 4 Fan Jia 2019-03-29 07:20:33 UTC
No avaialbe payload for the bug verification, 4.0.0-0.nightly-2019-03-29-040459 can't be installed success.

Comment 17 Colin Walters 2019-03-29 14:20:11 UTC
I think a root of confusion here is that there are multiple release payloads.  This bug is about the OCP payload, which is different from what CI uses.

http://post-office.corp.redhat.com/archives/aos-devel/2019-March/msg00120.html

I think the ART promotion to machine-os-content went into the OCP stream, which is what this bug is about.

Comment 19 Steve Milner 2019-03-29 14:41:02 UTC
Colin,

That's a good catch. There may be two issues we're tracking here:

1. The content generated by ART is not what we expected
2. The OCP stream has a copy of the content which is not expected

Comment 21 Steve Milner 2019-03-29 15:17:40 UTC
At this point things should be in working order once more.

Comment 24 Jian Zhang 2019-04-02 13:26:25 UTC
We can get the OperatorHub UI now, but there are two problems:
1) there is a dividing line between the "Installed Operators" and the "Operator Hub" on the UI.
2) Click the "Catalog"->"Operator Hub", and pull the scroll bar to the bottom, but it will go back to the top automatically.

[jzhang@dhcp-140-18 ocp42]$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.0.0-0.nightly-2019-04-02-081046   True        False         133m    Cluster version is 4.0.0-0.nightly-2019-04-02-081046
The OLM version:
               io.openshift.build.commit.id=9ba3512c5406b62179968e2432b284e9a30c321e
               io.openshift.build.commit.url=https://github.com/operator-framework/operator-lifecycle-manager/commit/9ba3512c5406b62179968e2432b284e9a30c321e

Comment 27 Jian Zhang 2019-04-03 01:59:40 UTC
For the 2nd issue I described in comment 24, it only occurs on the Safari browser, it works well on the Chrome and Firefox.
For the 1st issue I mentioned, I guess it's as designed for the permission restriction. Correct me if I'm wrong.

Comment 29 Jian Zhang 2019-04-03 06:42:58 UTC
Sudha,

Thanks for your information! I see, for issues in comment 24, I created bug 1695446 to trace it.
For this bug, I'd like to verify it. Thanks!

Comment 31 errata-xmlrpc 2019-06-04 10:46:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.