Bug 169390 - Dovecot requires saslauthd to work but does not declare that
Dovecot requires saslauthd to work but does not declare that
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 16:03 EDT by Paolo Campegiani
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 18:56:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Campegiani 2005-09-27 16:03:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

Description of problem:
This is not a bug, more a lack in documentation or diagnostic messages.

I've encountered this problem when I was required to fix a IMAP server, running dovecot, which timeouts every IMAP-POP3 login. I realized the problem was saslauthd wasn't running on the machine, but I didn't find any clue in /var/log/messages or /var/log/maillog, I was just lucky to find the problem :)

I think you should find a way to enable saslauthd when dovecot starts (maybe changing the /etc/init.d scripts), or at least print some help information in a log file. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Stop saslauthd
2. Start dovecot
3. Try to download your mail
  

Actual Results:  Login expires after a timeout, with no messages in a log file.

Expected Results:  At least an error message ("saslauthd not working, unable to authenticate") should be found.

Additional info:
Comment 1 John Dennis 2005-09-27 18:56:23 EDT
Your statement that dovecot requires salauthd to work is not correct. Dovecot
may require saslauthd if it is configured to use sasl. Also, saslauthd can be
utilized by any number of other sasl clients besides just dovecot. Therefore it
would not be correct for dovecot to manage saslauthd, either by starting it or
configuring it.

However, I do have sympathy for your frustration with understanding the whole
gamut of authtentication issues which arise when setting up various servers that
require authentication. The information is out there, but its sometimes hard to
find and put together into a cohesive whole with a simple step by step receipe.
We should provide better documentation in this area. But please note that
authentication applies to many services besides dovecot, servers may share
authentication or may keep private authentication information, and there are
wide variety of authentication databases, mechanisms, and ways to configure
individual servers to use them. Alas, this documentation would probably be an
entire book, which is why it probably hasn't been done yet.

You can find dovecot documentation on authentication here:

/usr/share/doc/dovecot-*/auth.txt
http://wiki.dovecot.org/moin.cgi/Authentication

I'm going to close this bug report because its not really a dovecot issue, but
please feel free to either create a new bug report specific to documentation.
Maybe one day one of us will write the book on authentication ;-)

Note You need to log in before you can comment on or make changes to this bug.