Bug 16940 - joe crashes with core dump
Summary: joe crashes with core dump
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: joe   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-25 14:52 UTC by Pytela, Zdenek
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-25 14:52:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pytela, Zdenek 2000-08-25 14:52:44 UTC
Editor joe from joe-2.8-24 cannot be executed, it looks like strcpy bug.
If no ~/.joerc is presented, the editor works.
If edited file exists, joe starts and freezes.
This was observed on a fresh installation with Czech locales and .joerc.
--
$ joe non-existing-file
Processing '.joerc'...Processing '.joerc'...Processing
'/usr/lib/joe/joerc'...Segmentation fault
--
End of strace output:

open("/usr/lib/joe/joerc", O_RDONLY)    = 6
write(2, "Processing \'/usr/lib/joe/joerc\'."..., 34) = 34
fstat(6, {st_mode=S_IFREG|0644, st_size=17169, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0x40017000
read(6, "\n                         Initia"..., 4096) = 4096
read(6, "ro\t\tMacro to execute when new fi"..., 4096) = 4096
brk(0x807c000)                          = 0x807c000
brk(0x807d000)                          = 0x807d000
read(6, "\\i\n\\i \\i Hit TAB at file name pr"..., 4096) = 4096
brk(0x807e000)                          = 0x807e000
brk(0x807f000)                          = 0x807f000
brk(0x8080000)                          = 0x8080000
brk(0x8081000)                          = 0x8081000
--- SIGSEGV (Neopravnln} pxmstup do pamlti (SIGSEGV)) ---
+++ killed by SIGSEGV +++
--
$ gdb joe core
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
Core was generated by `joe bla'.
Program terminated with signal 11, Neopravnln} pxmstup do pamlti (SIGSEGV).
Reading symbols from /usr/lib/libncurses.so.4...(no debugging symbols
found)...
done.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
#0  strcpy (dest=0x6372 <Address 0x6372 out of bounds>, src=0x80799e5
"\e[6~")
    at ../sysdeps/generic/strcpy.c:38
38      ../sysdeps/generic/strcpy.c: 
tup do pamlti (SIGSEGV)) ---
+++ killed by SIGSEGV +++

Comment 1 Trond Eivind Glomsrxd 2000-08-27 16:02:00 UTC
Can't reproduce with the one in Rawhide... and I know we have some fixes for 
memory issues there.


Note You need to log in before you can comment on or make changes to this bug.