Bug 169416 - /etc/init.d/named insists on /etc/named.conf, although this can be changed
/etc/init.d/named insists on /etc/named.conf, although this can be changed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
RHEL4U3NAK
:
Depends On: 170357
Blocks: 181409
  Show dependency treegraph
 
Reported: 2005-09-27 21:11 EDT by Bojan Smojver
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0288
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-10 17:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/init.d/named (5.19 KB, text/plain)
2005-09-28 10:53 EDT, Jason Vas Dias
no flags Details

  None (edit)
Description Bojan Smojver 2005-09-27 21:11:08 EDT
Description of problem:
The init script /etc/init.d/named insists on ${ROOTDIR}/etc/named.conf being
present, although this could have been overridden by the OPTIONS variable in
/etc/sysconfig/named (for instance, one may say -c /etc/myownbind/named.conf).

Version-Release number of selected component (if applicable):
bind-9.2.4-2


How reproducible:
Always.

Steps to Reproduce:
1. Move /etc/named.conf somewhere else.
2. Adjust /etc/sysconfig/named to have OPTIONS="-c /the/other/named.conf"
3. Attempt to start named.
  
Actual results:
Bind won't start because /etc/named.conf isn't there.


Expected results:
The script should take into account the -c option and check for that file instead.

Additional info:
N/A
Comment 1 Jason Vas Dias 2005-09-28 10:53:38 EDT
Created attachment 119370 [details]
/etc/init.d/named

Here's the named initscript to fix this issue :
# cp named.init /etc/init.d/named
# chown root:root /etc/init.d/named
# chmod 750 /etc/init.d/named
Comment 2 Jason Vas Dias 2005-09-28 10:55:51 EDT
The /etc/init.d/named script that fixes this issue is attached above .
It will be included in the next bind release for RHEL-4 (bind-9.2.4-11+) 
in RHEL-4-U3.
You can get the latest BIND release for RHEL-4 from:
   http://people.redhat.com/~jvdias/BIND/RHEL-4
Comment 3 Bojan Smojver 2005-09-28 18:38:18 EDT
Thanks. That was quick :-)

I can only see the i386 RPMS there. Can we have the SRPMS uploaded so we can
build x84_64 version ourselves?
Comment 4 Jason Vas Dias 2005-09-29 11:43:13 EDT
In reply to Comment #3: 
   Sorry, some files were mistakenly removed from the web server due to quota 
   issues.
   There are now these versions of BIND for RHEL-4 available:
      http://people.redhat.com/~jvdias/BIND/RHEL-4/9.2.4-10_EL4
         likely to be the next version in RHEL-4-U3, this has
         all serious ISC BIND 9.2.5 bug fixes backported
      http://people.redhat.com/~jvdias/BIND/RHEL-4/9.3.1-4_EL4
         This is ISC BIND 9.3.1, with many new features over 9.2.4 ,
         which we cannot submit to RHEL-4.
NOTE: this particular bug is not fixed in either of the above releases -
you'd still need to use the /etc/init.d/named script attached to this bug
report to fix this issue. The fixed initscript will be submitted to 
bind-9.2.4-11+_EL4 / bind-9.3.1-5+_EL4 and made available on the same
http://people.redhat.com/~jvdias/BIND/RHEL-4/ website shortly, and should 
be in RHEL-4-U3.
Comment 5 Bojan Smojver 2005-09-29 16:31:00 EDT
Thank you very much for your help! I will get those SRPMS and the init script
and roll our own from it.

BTW, I'm sure you mean RHEL-4-U2, not RHEL-4-U3...
Comment 6 Jason Vas Dias 2005-09-29 16:39:12 EDT
The binary RPMs for all platforms are built on our buildservers and available at
the above location - you do not need to 'roll your own'.
Use the init script  attached to this bug report for any BIND version.
Yes, I did mean RHEL-4-U3 - RHEL-4-U2 does not have any BIND update.
Comment 7 Bojan Smojver 2005-09-29 16:44:44 EDT
But if I want to have a clean RPM that doesn't need any external file copying
and includes that init script, I will need to roll my own. That's what I was
referring to.

Get the U2 v. U3 thing. I guess U2 has already been cut, so these come too late.
That's cool.
Comment 8 Bojan Smojver 2005-10-07 01:14:52 EDT
Looks good here.
Comment 11 Jason Vas Dias 2005-11-28 17:53:22 EST
This was fixed with bind-9.2.4-12_EL4+ (current release bind-9.2.4-16.EL4),
submitted in CVS, associated with errata RHBA-2006:020 and a candidate for 
the next RHEL-4 update release.
Comment 18 Bob Johnson 2006-04-11 11:57:22 EDT
This issue is on Red Hat Engineering's list of planned work items 
for the upcoming Red Hat Enterprise Linux 4.4 release.  Engineering 
resources have been assigned and barring unforeseen circumstances, Red 
Hat intends to include this item in the 4.4 release.
Comment 21 Red Hat Bugzilla 2006-08-10 17:13:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0288.html

Note You need to log in before you can comment on or make changes to this bug.