Bug 1694170 - [RFE] Support AVIC on AMD CPUs [NEEDINFO]
Summary: [RFE] Support AVIC on AMD CPUs
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: future
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 17:06 UTC by Ryan
Modified: 2022-04-11 09:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-08 16:34:14 UTC
oVirt Team: Virt
rbarry: needinfo? (nsimsolo)
sbonazzo: ovirt-4.5-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHV-37624 0 None None None 2021-10-25 11:38:42 UTC

Description Ryan 2019-03-29 17:06:17 UTC
Description of problem:

Cannot use AVIC with AMD CPUs. AVIC helps accelerate interrupts in virtual environments. If AVIC is enabled oVirt reports the CPU type as unsupported because AVIC conflicts with x2apic. The x2apic flag is added to every CPU model by default when kvm is enabled (see the RHEL bug below).

Enabling AVIC worked under 4.2, but 4.3 seems to be more strict with detecting CPU features/capabilities.

See the following bugzilla reports for more information:
Initial oVirt report for unsupported CPU type:
https://bugzilla.redhat.com/show_bug.cgi?id=1674265

RHEL Bug for x2apic flag requirement, and details the problem at the qemu/libvirt level:
https://bugzilla.redhat.com/show_bug.cgi?id=1675030

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set host to maintenance mode.
2. Set the kvm module option 'options kvm_amd avic=1'.
3. Clear the capabilities cache rm -f /var/cache/libvirt/qemu/capabilities/*.xml
4. Reboot the host or reload the kvm module and restart libvirtd
5. Try to activate the host.

Actual results:
Reports CPU type as unsupported.

Expected results:
Host activates, can use AVIC. Either oVirt ignores the x2apic flag mismatch or directly supports the AVIC flag.

Additional info:
Tested on AMD EPYC 7551P

Comment 1 Michal Skrivanek 2020-03-18 15:35:40 UTC
can you please doublecheck the latest state in AV 8.2?

Comment 2 Ryan Barry 2020-03-18 15:48:34 UTC
Nisim, I don't have AMD hardware available. Can you check, please?

Comment 5 Sandro Bonazzola 2022-03-29 16:16:40 UTC
We are past 4.5.0 feature freeze, please re-target.

Comment 6 Michal Skrivanek 2022-04-08 16:34:14 UTC
in 8.6 it may very well work, but closing the bug as we don't seem to have anyone who can verify this


Note You need to log in before you can comment on or make changes to this bug.