Bug 1694183 - Git commit passed to hyperkube RPM build is incorrect and reports back to cluster the wrong version
Summary: Git commit passed to hyperkube RPM build is incorrect and reports back to clu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Luke Meyer
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 17:31 UTC by Clayton Coleman
Modified: 2019-06-04 10:46 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:47 UTC

Description Clayton Coleman 2019-03-29 17:31:18 UTC
The hyperkube binary is used to launch the kubelet on the node and reports back its version number to the cluster as part of the Node object. We need the commit reported to match a real commit accessible in the openshift/origin and openshift/ose history so that we can identify which code is in use.

The rpm build script when involved by ART jobs should ensure that the commit reported by hyperkube and the RPM version label should match a real, reachable OSE commit.

Luke confirmed this is still an issue post-incremental, tracking here so we don't forget.  Does not block beta3

Comment 1 Luke Meyer 2019-04-10 22:09:31 UTC
This *should* be correct now. It should be evident once we actually get a 4.1 payload.

Comment 4 Mike Fiedler 2019-05-03 15:21:29 UTC
Verified on 4.1.0-0.nightly-2019-05-03-093152


From the Node:
    kubeProxyVersion: v1.13.4+b347a89d6
    kubeletVersion: v1.13.4+b347a89d6

Verified this matches the commit in OSE

Comment 6 errata-xmlrpc 2019-06-04 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.