Bug 1694213 - Compute Nodes Need br-ex for OVN
Summary: Compute Nodes Need br-ex for OVN
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Kamil Sambor
QA Contact: Sasha Smolyak
URL:
Whiteboard:
: 1698653 1713464 (view as bug list)
Depends On:
Blocks: 1713699
TreeView+ depends on / blocked
 
Reported: 2019-03-29 19:31 UTC by Dan Sneddon
Modified: 2019-10-22 07:59 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190701110422.889d4d4.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:05 UTC
Target Upstream Version:
ksambor: needinfo+
ksambor: needinfo+


Attachments (Terms of Use)
computeovsdpdk sos report (6.38 MB, application/x-xz)
2019-05-27 07:25 UTC, yogananth subramanian
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1822367 0 None None None 2019-03-29 19:31:37 UTC
OpenStack gerrit 663850 0 None MERGED Add creating br-ex for compute node in ovn 2020-12-22 12:42:11 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:23 UTC

Description Dan Sneddon 2019-03-29 19:31:38 UTC
Description of problem:
OVN uses distributed routing by default, similar to how ML2/OVS did DVR. This means that the compute nodes need a br-ex bridge by default, just like the controllers, but with no IP.

Version-Release number of selected component (if applicable):
OSP 15

How reproducible:
100%

Steps to Reproduce:
1. Deploy with existing configs
2.
3.

Actual results:
Unless the "compute-dvr.yaml" template is used with the multiple-nics templates, the Compute nodes will have no br-ex and external routing does not work.

Expected results:
Compute nodes should have a br-ex bridge (or a different name if the NeutronBridgeMappings are not "datacentre:br-ex").

Additional info:
We will have multiple releases that need to support both OVS and OVN. We may want to create a mechanism where the bridge is enabled via flag, so that either option can be easily deployed.

Comment 3 Bob Fournier 2019-04-11 14:19:03 UTC
*** Bug 1698653 has been marked as a duplicate of this bug. ***

Comment 7 Bob Fournier 2019-05-23 23:30:26 UTC
*** Bug 1713464 has been marked as a duplicate of this bug. ***

Comment 8 yogananth subramanian 2019-05-27 07:23:59 UTC
ovs_neutron_agent in compute node terminates if Bridge br-ex is not present.

2019-05-23 13:22:00.165 24758 ERROR neutron.plugins.ml2.drivers.openvswitch.agent.ovs_neutron_agent [req-08f03002-4bee-4acd-ace2-73097f699c12 - - - - -] Bridge br-ex for physical network datacentre does not exist. Agent terminated!

Comment 9 yogananth subramanian 2019-05-27 07:25:32 UTC
Created attachment 1573782 [details]
computeovsdpdk sos report

Comment 10 Bob Fournier 2019-06-05 23:55:43 UTC
Moving to ON_DEV until patch merges and is backported to stable/stein.

Comment 12 Alistair Tonner 2019-07-11 17:39:39 UTC
Compute nodes now create correctly with bridge when using OSP15 geneve/DVR
Code verified.

Comment 16 errata-xmlrpc 2019-09-21 11:21:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.