Bug 1694222 - kube-apiserver operator failed to upgrade
Summary: kube-apiserver operator failed to upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.1.0
Assignee: David Eads
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-29 19:55 UTC by Ben Parees
Modified: 2019-06-04 10:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:47 UTC

Description Ben Parees 2019-03-29 19:55:44 UTC
Description of problem:
Mar 29 07:18:46.840: INFO: cluster upgrade is failing: Cluster operator kube-apiserver is still updating: upgrading kube-apiserver from  to 1.12.4

https://openshift-gce-devel.appspot.com/build/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-upgrade-4.0/731

How reproducible:
flake


Note:  We are seeing this form of failure for several operators, I will cross link them as i open the bugs.

I have not dug into whether this operator specifically failed to upgrade, or if something earlier in the process took so long that this operator was the "victim" of the eventual timeout.  As you investigate the job that failed, feel free to reassign this if you think there is a root cause that is independent of your operator.

If your operator currently lacks sufficient events/logs/etc to determine when it started upgrading and what it was doing when we timed out, consider using this bug to introduce that information.

Comment 1 Ben Parees 2019-03-29 19:57:08 UTC
Related operator failed to upgrade bugs:
https://bugzilla.redhat.com/show_bug.cgi?id=1694216
https://bugzilla.redhat.com/show_bug.cgi?id=1694220

Comment 3 Michal Fojtik 2019-04-05 13:00:06 UTC
Operator versioning was reworked recently, we haven't seen this since that, moving to QA.

Comment 4 Xingxing Xia 2019-04-08 06:45:43 UTC
Upgrade testing from 4.0.0-0.10 to 4.0.0-0.11 succeeds without the issue, moving to VERIFIED.

Comment 6 errata-xmlrpc 2019-06-04 10:46:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.