Bug 169431 - cannot install additional dictionaries
cannot install additional dictionaries
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mozilla (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 04:15 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-09-28 04:15:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.7.12-1.1.3.2

Description of problem:
Hi,

Unable to load new dictionaries into mozilla mail client following
recent redhat network up2date.

Following the recent up2date I found that I had lost my Australian
english dictionary. I attempted to download again, which proceeded with
no error messages and proclaiming success. However this optimism was
unfounded and I believe that the problem is an inappropriate directory
ownership which prevents a user installing a new dictionary. This used
to work. Installed dictionaries are removed in the rpm installation.

After initial installation...

[root@aatpc23 cmc]# ls -lac /usr/lib/mozilla-1.7.12/components/myspell
total 700

drwxr-xr-x    2 root     root         4096 Sep 26 14:43 .
drwxr-xr-x    3 root     root         8192 Sep 28 12:28 ..
-rw-r--r--    1 root     root         2730 Sep 26 14:43 en-US.aff
-rw-r--r--    1 root     root       695727 Sep 26 14:43 en-US.dic

Changed protections...

[root@aatpc23 cmc]# chmod 777 /usr/lib/mozilla-1.7.12/components/myspell
[root@aatpc23 cmc]# ls -lac /usr/lib/mozilla-1.7.12/components/myspell
total 700
drwxrwxrwx    2 root     root         4096 Sep 28 14:32 .
drwxr-xr-x    3 root     root         8192 Sep 28 12:28 ..
-rw-r--r--    1 root     root         2730 Sep 26 14:43 en-US.aff
-rw-r--r--    1 root     root       695727 Sep 26 14:43 en-US.dic

and success...

[root@aatpc23 cmc]# ls -lac /usr/lib/mozilla-1.7.12/components/myspell
total 1240
drwxrwxrwx    2 root     root         4096 Sep 28 14:33 .
drwxr-xr-x    3 root     root         8192 Sep 28 12:28 ..
-rw-rw-r--    1 cmc      cmc         27375 Sep 28 14:33 en-AU.aff
-rw-rw-r--    1 cmc      cmc        513822 Sep 28 14:33 en-AU.dic
-rw-r--r--    1 root     root         2730 Sep 26 14:43 en-US.aff
-rw-r--r--    1 root     root       695727 Sep 26 14:43 en-US.dic
-rw-rw-r--    1 cmc      cmc          1299 Sep 28 14:33 README-en-AU.txt
[root@aatpc23 cmc]#

[root@aatpc23 cmc]# uname -a
Linux aatpc23 2.4.21-32.0.1.EL #1 Tue May 17 18:01:37 EDT 2005 i686 i686 i386 GNU/Linux

[root@aatpc23 cmc]# rpm -qa | grep mozilla
mozilla-nspr-1.7.12-1.1.3.2
mozilla-mail-1.7.12-1.1.3.2
mozilla-js-debugger-1.7.12-1.1.3.2
mozilla-dom-inspector-1.7.12-1.1.3.2
mozilla-chat-1.7.12-1.1.3.2
mozilla-1.7.12-1.1.3.2
mozilla-nss-1.7.12-1.1.3.2
[root@aatpc23 cmc]#

[cmc@aatpc23 ~]$  cat /etc/redhat-release
Red Hat Enterprise Linux WS release 3 (Taroon Update 5)
[cmc@aatpc23 ~]$


Regards,
Chris


Version-Release number of selected component (if applicable):
mozilla-1.7.12-1.1.3.2

How reproducible:
Always

Steps to Reproduce:
1.Spell check a composed message
2.Download and install Australian dictionary
3.No new dictionary offered after a restart of mozilla
  

Actual Results:  Nothing, no new dictionary offered after a restart of mozilla
  

Expected Results:  Should have had the option of using a new dictionary successfully installed.

Additional info:

Used to work, broken by an up2date run.
Comment 1 Christopher Aillon 2005-09-28 14:09:24 EDT
Which version did this work in?  The permissions haven't changed as far as I'm
aware.  Is it possible you previously installed dictionaries as root?
Comment 2 Need Real Name 2005-09-29 03:11:26 EDT
Thanks for your prompt reply.

Not absolutely sure, but looking at /var/spool/up2date shows
mozilla-1.7.10-1.1.3.2.i386.rpm as the penultimate rpm.

Pretty confident I never installed as root because you can only install a
dictionary from a spell check on the compose email window and you can only get
there if you have set up a mail account as root, which I have not done. 

Another point, surely that would only have set the actual files e.g. en-AU.dic
and not the directory itself.

Can you install dictionaries on a test machine or poke around the rpm to check
its protections? 
Comment 3 RHEL Product and Program Management 2007-10-19 14:53:44 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.