Bug 1694411 - Segfault when using zchunk metadata
Summary: Segfault when using zchunk metadata
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: librepo
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Jaroslav Rohel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
: 1694643 1694653 1695616 (view as bug list)
Depends On:
Blocks: F30FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-03-31 08:03 UTC by Jonathan Dieter
Modified: 2019-04-08 11:58 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-04 00:01:41 UTC


Attachments (Terms of Use)

Description Jonathan Dieter 2019-03-31 08:03:24 UTC
Description of problem:
dnf crashes with a segfault when zchunk metadata is used

Version-Release number of selected component (if applicable):
librepo-1.9.6-1.fc30

How reproducible:
Always

Steps to Reproduce:
1. Run dnf update

Actual results:
$ dnf update
Fedora Modular 30 - x86_64 - Test Updates                                                                                                    1.4 MB/s | 2.1 MB     00:01    
Fedora 30 - x86_64 - Test Updates                                                                                                            2.7 MB/s |  11 MB     00:03    
Segmentation fault (core dumped)                                        [               ===                                                ] ---  B/s |   0  B     --:-- ETA

Expected results:
dnf update works

Additional info:
librepo-1.9.5-1.fc30 works perfectly
This is affecting Rawhide compose too: https://pagure.io/dusty/failed-composes/issue/1773

Comment 1 Jonathan Dieter 2019-03-31 17:47:09 UTC
PR to fix the bug at:
https://github.com/rpm-software-management/librepo/pull/148

Comment 2 Jonathan Dieter 2019-03-31 17:52:27 UTC
FWIW, it looks like the bug was introduced in https://github.com/rpm-software-management/librepo/commit/3549e61bd34213b421c49f942db2576d327ca1c5, where h was changed to target->curl_handle for everything except the zchunk code, where it was instead set to target->handle.

Comment 3 Jaroslav Rohel 2019-04-01 11:41:50 UTC
*** Bug 1694653 has been marked as a duplicate of this bug. ***

Comment 4 Jaroslav Rohel 2019-04-01 11:59:53 UTC
*** Bug 1694643 has been marked as a duplicate of this bug. ***

Comment 5 Jonathan Dieter 2019-04-01 18:13:00 UTC
Jaroslav, thanks so much for merging the PR.  Will we be getting an update in F30 and Rawhide today or tomorrow?  Thanks!

Comment 6 Jonathan Dieter 2019-04-02 10:57:23 UTC
Hey, not meaning to be pushy, but can we please get this built today? We've had to shut off zchunk metadata on the F30 updates repositories until this gets fixed, and we're running late enough that it might have already pushed the feature back to F31.

Comment 7 Miro Hrončok 2019-04-02 11:54:51 UTC
Jonathan, if you open a Fedora PR, I'll gladly review, merge and build as a provenpackager.

Comment 8 Miro Hrončok 2019-04-02 11:55:37 UTC
Anyway, I consider this urgent if we want to do this today. Setting the severity accordingly.

Comment 9 Miro Hrončok 2019-04-02 11:56:11 UTC
(In reply to Miro Hrončok from comment #7)
> Jonathan, if you open a Fedora PR, I'll gladly review, merge and build as a
> provenpackager.

Too late: https://src.fedoraproject.org/rpms/librepo/c/0cc00ce9db0470cce915c4562a342d385732d3fd?branch=master

Comment 10 Pavla Kratochvilova 2019-04-02 11:56:59 UTC
Yes, I am making the build right now.

Comment 12 Fedora Update System 2019-04-02 12:03:03 UTC
librepo-1.9.6-2.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-07c3e09858

Comment 13 Fedora Blocker Bugs Application 2019-04-02 12:07:17 UTC
Proposed as a Blocker for 30-final by Fedora user churchyard using the blocker tracking app because:

 "The installed system must be able appropriately to install, remove, and update software with the default console tool for the relevant software type (e.g. default console package manager). This includes downloading of packages to be installed/updated."

Comment 14 Fedora Update System 2019-04-02 12:08:04 UTC
librepo-1.9.6-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-daf980b401

Comment 15 Jonathan Dieter 2019-04-02 12:23:39 UTC
Guys, thanks so much for pushing this through.  For full testing, you'll want to point one of the repositories to rawhide which has zchunk metadata.

Comment 16 Fedora Update System 2019-04-03 02:27:21 UTC
librepo-1.9.6-2.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-07c3e09858

Comment 17 Fedora Update System 2019-04-03 04:37:55 UTC
librepo-1.9.6-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-daf980b401

Comment 18 Fedora Update System 2019-04-04 00:01:41 UTC
librepo-1.9.6-2.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2019-04-04 03:11:17 UTC
librepo-1.9.6-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Jaroslav Rohel 2019-04-08 11:58:33 UTC
*** Bug 1695616 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.