Bug 169442 - [gcj] oowriter crashes after saving as DocBook or MS Word 2003 XML
[gcj] oowriter crashes after saving as DocBook or MS Word 2003 XML
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 09:03 EDT by bastiaan
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.0-3.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 03:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stack trace generated by OOo (3.33 KB, text/plain)
2005-09-28 09:03 EDT, bastiaan
no flags Details
backtrace (11.84 KB, application/octet-stream)
2005-10-02 06:02 EDT, Caolan McNamara
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 55322 None None None Never

  None (edit)
Description bastiaan 2005-09-28 09:03:04 EDT
Description of problem:
When saving a document in DocBook or MS Word 2003 XML two things go wrong:
1) the resulting document is empty
2) oowriter crashes shortly afterwards

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.125-1.1.0.fc4

How reproducible:
always

Steps to Reproduce:
1. open oowriter
2. type some text
3. 'Save As' filetype DocBook or MS Word 2003 XML
  
Actual results:
The saved document is empty, oowriter crashes within about 10 seconds after saving.

Expected results:
A nice DocBook document on my disk and a running oowriter on my desktop

Additional info:
Looks like the crash occurs in the first garbage collection after the save
operation. I've attached the stack trace OOo spits out.
Comment 1 bastiaan 2005-09-28 09:03:04 EDT
Created attachment 119357 [details]
stack trace generated by OOo
Comment 2 bastiaan 2005-09-29 05:50:28 EDT
retested with openoffice.org-writer-2.0.0-1.1.2. Results:

1) 'Save As' filetype DocBook has been removed :-(
2) 'Save As' filetype MS Word 2003 XML: OOo no longer crashes, but outputs a
'general IO error' dialog during the save command and hangs. 


Comment 3 Caolan McNamara 2005-09-29 06:21:48 EDT
docbook isn't removed, it's in the xsltfilter package
Comment 4 Caolan McNamara 2005-10-02 06:02:38 EDT
Created attachment 119517 [details]
backtrace
Comment 5 Caolan McNamara 2005-10-03 05:37:35 EDT
ok, the 2.0.0-1 problem can be tracked to a silly change in a licence which
threw out some xslt code :-), now logged as
http://www.openoffice.org/issues/show_bug.cgi?id=55383 and fixed in the next
rawhide OOo release. We'll revisit the crashing issue on the update to 2.0.0 for
FC4 pending soon.

Note You need to log in before you can comment on or make changes to this bug.