Bug 1694444 - Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.32), passed through in regex; marked by <-- HERE in m/ ( { <-- HERE } (?: / \* )? | \* ) / at (eval 97) line 830.
Summary: Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: amavisd-new
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Juan Orti
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-03-31 14:40 UTC by dac.override
Modified: 2020-09-19 13:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-19 13:45:46 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gitlab amavis/amavis/issues/31 0 None None None 2019-05-11 08:45:26 UTC

Description dac.override 2019-03-31 14:40:09 UTC
Description of problem:
Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.32), passed through in regex; marked by <-- HERE in m/ ( { <-- HERE } (?: / \* )? | \* ) / at (eval 97) line 830.

They fixed it here:

https://bz-attachments.freebsd.org/attachment.cgi?id=200278

Comment 1 Ben Cotton 2019-08-13 16:55:21 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to '31'.

Comment 2 Ben Cotton 2019-08-13 19:20:59 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 31 development cycle.
Changing version to 31.

Comment 3 Paul Howarth 2019-08-14 10:59:09 UTC
Upstream ticket is now closed, fix merged.

Comment 4 Fedora Admin user for bugzilla script actions 2020-06-26 14:50:47 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 5 Fedora Admin user for bugzilla script actions 2020-08-05 09:16:34 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 6 Juan Orti 2020-09-19 13:45:46 UTC
The fix for this issue is released in amavis-2.12.0


Note You need to log in before you can comment on or make changes to this bug.