Bug 169445 - Mgopen fonts a litle bit truncated in display
Mgopen fonts a litle bit truncated in display
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mgopen-fonts (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Sarantis Paskalis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 09:29 EDT by Nikos Charonitakis
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 17:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
canonica (6.56 KB, image/png)
2005-09-28 09:39 EDT, Nikos Charonitakis
no flags Details
cosmetica (10.43 KB, image/png)
2005-09-28 09:40 EDT, Nikos Charonitakis
no flags Details
modata (2.58 KB, image/png)
2005-09-28 09:41 EDT, Nikos Charonitakis
no flags Details
moderna (5.48 KB, image/png)
2005-09-28 09:42 EDT, Nikos Charonitakis
no flags Details
evolution screenshot with moderna in greek (5.69 KB, image/png)
2005-09-28 10:44 EDT, Sarantis Paskalis
no flags Details
evolution running with Sans font in a en_US locale (5.94 KB, image/png)
2005-09-28 17:23 EDT, Sarantis Paskalis
no flags Details

  None (edit)
Description Nikos Charonitakis 2005-09-28 09:29:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
i ve installed mgopen-fonts on FC4 and there are some display issues with Greek characters.
I select mgopen-cosmetica (example) for applications font through font-preferences application and some characters are truncated in display.
My attachments so exactly the problem...
Is this a fontconfig issue? or the mgopen fonts have some problems?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. installe and use mgopen-fonts (greek)
2.
3.
  

Additional info:
Comment 1 Nikos Charonitakis 2005-09-28 09:39:03 EDT
Created attachment 119359 [details]
canonica

see the last letter (htta) of the last button (metakinisi)
Comment 2 Nikos Charonitakis 2005-09-28 09:40:35 EDT
Created attachment 119360 [details]
cosmetica

see first and last button sigma and alpha are truncated
Comment 3 Nikos Charonitakis 2005-09-28 09:41:35 EDT
Created attachment 119361 [details]
modata

similar problem
Comment 4 Nikos Charonitakis 2005-09-28 09:42:29 EDT
Created attachment 119362 [details]
moderna

similar problem
Comment 5 Sarantis Paskalis 2005-09-28 10:43:04 EDT
Can't reproduce here, my screenshot with moderna attached.

Does this happen with apps other than evolution?  Can you see it in the Gnome
menus for example?
Comment 6 Sarantis Paskalis 2005-09-28 10:44:44 EDT
Created attachment 119369 [details]
evolution screenshot with moderna in greek
Comment 7 Simos Xenitellis 2005-09-28 11:03:59 EDT
It might be an issue with the size of the fonts; a little bit larger and there
could be trancation.

Sarantis, could you try increasing the size of the font and see if you can
reproduce?

(I do not have FC4 at the moment).
Comment 8 Sarantis Paskalis 2005-09-28 17:22:32 EDT
I can see cropping, but not only at the last character.  The evolution buttons
have a maximum or fixed size, and anything beyond that size gets truncated.  See
attachment at comment #4.  The whole character at the final sigma is missing.

See also the next attachment, which shows the same behavior at a en_US locale
using Sans size 11.  So, this is a font-independent, locale-independent behavior.

I think it shows up in the greek locale, due to the larger space it needs for
the function description in the buttons.

Closing it NOTABUG.  Please file an evolution bug if you think it needs more
space for button descriptions in non-English languages.
Comment 9 Sarantis Paskalis 2005-09-28 17:23:34 EDT
Created attachment 119391 [details]
evolution running with Sans font in a en_US locale
Comment 10 Simos Xenitellis 2005-09-29 17:27:25 EDT
The problem appears to originate from the on-the-fly chaning of the UI font.
When you change font, it appears that the spacing of the characters is not
updated  on the fly as well; you simply need to restart to fix this problem.

Therefore, it still remains as NOTABUG per se but a feature in the on-the-fly
mechanism, when changing fonts.
It could be posted as a bug to GTK+.

Note You need to log in before you can comment on or make changes to this bug.