Bug 169450 - recent mkinitrd all break RAID - kernel panic
recent mkinitrd all break RAID - kernel panic
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 10:15 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-29 17:55:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-09-28 10:15:15 EDT
Description of problem:
recent mkinitrd all break RAID - kernel panic - something about not finding
/dev/console

Failure occurs with three recent version os mkinitrd on both x86_64 and i386

Non-raid systems seem OK.

Reverting to mkinitrd-4.2.21-1 fixes the problem.

Version-Release number of selected component (if applicable):
mkinitrd-5.0.0-1
mkinitrd-4.2.23-2
mkinitrd-4.2.22-1
kernel-2.6.13-1.1580_FC5

How reproducible:
100%

Steps to Reproduce:
1.reboot
2.
3.
  
Actual results:
Kernel panic  - something about /dev/console

Expected results:


Additional info:
Comment 1 Clyde E. Kunkel 2005-09-28 13:42:55 EDT
I believe the raidautorun command for each raid device is not being included
after mkinitrd-4.2.21-1.

ERROR opening /dev/console!!!!: 2
is the error before the panic.
Comment 2 John Ellson 2005-10-03 20:00:55 EDT
Seems to be fixed in kernel-2.6.13-1.1589_FC5, mkinitrd-5.0.3-1
Comment 3 Clyde E. Kunkel 2005-10-03 23:43:37 EDT
Not if fstab identifies the / partition by label, ie, LABEL=/somelabel....
Comment 4 John Ellson 2005-11-27 12:18:02 EST
Possibly related to bug #169069
Comment 5 Peter Jones 2005-11-29 17:55:07 EST
I don't get this error with current versions.  Please try them, and if you still
get this, reopen the bug with more detail on your setup.

Note You need to log in before you can comment on or make changes to this bug.