Bug 1694532 (CVE-2019-1003040) - CVE-2019-1003040 jenkins-plugin-script-security: Sandbox bypass in Script Security Plugin and Pipeline: Groovy Plugin (SECURITY-1353)
Summary: CVE-2019-1003040 jenkins-plugin-script-security: Sandbox bypass in Script Sec...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-1003040
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1694533 1694540 1694541
Blocks: 1694534
TreeView+ depends on / blocked
 
Reported: 2019-04-01 03:57 UTC by Sam Fowler
Modified: 2020-04-28 16:24 UTC (History)
22 users (show)

Fixed In Version: jenkins-plugin-script-security 1.56
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the Jenkins Script Security plugin. Groovy Plugins could be circumvented through methods supporting type casts and type coercion allowing attackers to invoke constructors for arbitrary types. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Clone Of:
Environment:
Last Closed: 2019-06-10 22:58:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1423 None None None 2019-06-10 16:58:23 UTC

Description Sam Fowler 2019-04-01 03:57:11 UTC
Sandbox projection in the Jenkins Script Security and Pipeline: Groovy Plugins could be circumvented through methods supporting type casts and type coercion. This allowed attackers to invoke constructors for arbitrary types.


External Reference:

https://jenkins.io/security/advisory/2019-03-25/#SECURITY-1353

Comment 1 Sam Fowler 2019-04-01 03:57:24 UTC
Created jenkins-script-security-plugin tracking bugs for this issue:

Affects: fedora-all [bug 1694533]

Comment 4 Sam Fowler 2019-04-01 05:22:08 UTC
"Any security advisory related updates to Jenkins core or the plugins we include in the OpenShift Jenkins master image will only occur in the v3.11 and v4.x branches of this repository."

https://github.com/openshift/jenkins/blob/master/README.md#jenkins-security-advisories-the-master-image-from-this-repository-and-the-oc-binary

Comment 5 errata-xmlrpc 2019-06-10 16:58:22 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.11

Via RHSA-2019:1423 https://access.redhat.com/errata/RHSA-2019:1423


Note You need to log in before you can comment on or make changes to this bug.