Bug 1694538 (CVE-2019-1003042) - CVE-2019-1003042 jenkins-plugin-lockable-resources: XSS vulnerability in Lockable Resources Plugin (SECURITY-1361)
Summary: CVE-2019-1003042 jenkins-plugin-lockable-resources: XSS vulnerability in Lock...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2019-1003042
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1694540 1694541
Blocks: 1694534
TreeView+ depends on / blocked
 
Reported: 2019-04-01 04:13 UTC by Sam Fowler
Modified: 2020-03-18 04:34 UTC (History)
19 users (show)

Fixed In Version: jenkins-plugin-lockable-resources 2.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 22:59:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1423 None None None 2019-06-10 16:58:27 UTC

Description Sam Fowler 2019-04-01 04:13:26 UTC
The Lockable Resources Jenkins Plugin did not properly escape resource names in generated JavaScript code, thus leading to a cross-site scripting (XSS) vulnerability.


External Reference:

https://jenkins.io/security/advisory/2019-03-25/#SECURITY-1361

Comment 3 Sam Fowler 2019-04-01 05:22:22 UTC
"Any security advisory related updates to Jenkins core or the plugins we include in the OpenShift Jenkins master image will only occur in the v3.11 and v4.x branches of this repository."

https://github.com/openshift/jenkins/blob/master/README.md#jenkins-security-advisories-the-master-image-from-this-repository-and-the-oc-binary

Comment 4 errata-xmlrpc 2019-06-10 16:58:26 UTC
This issue has been addressed in the following products:

  Red Hat OpenShift Container Platform 3.11

Via RHSA-2019:1423 https://access.redhat.com/errata/RHSA-2019:1423


Note You need to log in before you can comment on or make changes to this bug.