Bug 1694610 - glusterd leaking memory when issued gluster vol status all tasks continuosly
Summary: glusterd leaking memory when issued gluster vol status all tasks continuosly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 6
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1691164 1694612
Blocks: 1686255
TreeView+ depends on / blocked
 
Reported: 2019-04-01 09:04 UTC by Sanju
Modified: 2019-04-22 13:33 UTC (History)
9 users (show)

Fixed In Version: glusterfs-6.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1691164
Environment:
Last Closed: 2019-04-16 10:50:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 22467 None Merged glusterd: fix txn-id mem leak 2019-04-16 10:50:10 UTC

Description Sanju 2019-04-01 09:04:00 UTC
Description of problem:
glusterd is leaking memory when issused "gluster vol status tasks" continuosly for 12 hours. The memory increase is from 250MB to 1.1GB. The increase have been 750 MB.


Version-Release number of selected component (if applicable):
glusterfs-3.12.2

How reproducible:
1/1

Steps to Reproduce:
1. On a six node cluster with brick-multiplexing enabled
2. Created 150 disperse volumes and 250 replica volumes and started them
3. Taken memory footprint from all the nodes
4. Issued "while true; do gluster volume status all tasks; sleep 2; done" with a time gap of 2 seconds 

Actual results:
Seen a memory increase of glusterd on Node N1 from 260MB to 1.1GB

Expected results:
glusterd memory shouldn't leak

Comment 1 Sanju 2019-04-01 09:07:40 UTC
Root cause:

There's a leak of a key setting in the dictionary priv->glusterd_txn_opinfo in every volume status all transaction when cli fetches the list of volume names as part of the first transaction.

Comment 2 Worker Ant 2019-04-01 09:14:32 UTC
REVIEW: https://review.gluster.org/22467 (glusterd: fix txn-id mem leak) posted (#1) for review on release-6 by Sanju Rakonde

Comment 3 Worker Ant 2019-04-16 10:50:12 UTC
REVIEW: https://review.gluster.org/22467 (glusterd: fix txn-id mem leak) merged (#2) on release-6 by Shyamsundar Ranganathan

Comment 4 Shyamsundar 2019-04-22 13:33:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.1, please open a new bug report.

glusterfs-6.1 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-April/000124.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.