Bug 1694642 - TLS handshake timeout error from new installation
Summary: TLS handshake timeout error from new installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.1.0
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
: 1694639 (view as bug list)
Depends On:
Blocks: 1664187
TreeView+ depends on / blocked
 
Reported: 2019-04-01 10:17 UTC by Jaspreet Kaur
Modified: 2019-06-04 10:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:53 UTC

Description Jaspreet Kaur 2019-04-01 10:17:18 UTC
Description of problem: Created a new cluster but after 1 or 2 day we see TLS handshake timeout errors.

We cannot make oc login, we get this error:

oc login -u kubeadmin -p xxxxxxxxxxx
error: net/http: TLS handshake timeout

and if we try to access to web console we get the following error:
.....
The connection to openshift-authentication-openshift-authentication.apps.ocp4beta3.dev.xbyorange.com was interrupted while the page was loading.

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.

.....


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results: TLS errors appeared after 48 hours

Expected results: Shouldnt have faced the issue in a newly created cluster



Additional info:

Comment 4 Erica von Buelow 2019-04-04 19:30:55 UTC
*** Bug 1694639 has been marked as a duplicate of this bug. ***

Comment 6 Michal Fojtik 2019-04-16 08:58:16 UTC
This should be fixed on recent clusters as we extended the rotation intervals to 31 days and there were numerous fixes in certificate rotation.

Comment 7 Xingxing Xia 2019-04-17 04:30:49 UTC
Didn't meet it in env of latest Accepted payload 4.0.0-0.nightly-2019-04-10-182914 after ~2 days.

Comment 9 errata-xmlrpc 2019-06-04 10:46:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.