Bug 1694715 - on big katello-agent update: PG::StringDataRightTruncation: ERROR: value too long for type character varying(255)
Summary: on big katello-agent update: PG::StringDataRightTruncation: ERROR: value too...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Audit Log
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Released
Assignee: Marek Hulan
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 13:09 UTC by Jan Hutař
Modified: 2019-10-21 14:45 UTC (History)
5 users (show)

Fixed In Version: tfm-rubygem-katello-3.10.0.44-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:40:31 UTC


Attachments (Terms of Use)
Satellite side traceback (62.28 KB, text/plain)
2019-04-01 13:12 UTC, Jan Hutař
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:40:41 UTC
Foreman Issue Tracker 26547 None None None 2019-04-05 14:31:27 UTC

Description Jan Hutař 2019-04-01 13:09:27 UTC
Description of problem:
On big katello-agent update task fails with "PG::StringDataRightTruncation: ERROR:  value too long for type character varying(255)"


Version-Release number of selected component (if applicable):
satellite-6.5.0-10.el7sat.noarch (snap #22)


How reproducible:
always


Steps to Reproduce:
1. Install RHEL 7.4 host (now when 7.6 is out) and register to Satellite
2. Install katello-agent to the host
3. Hosts -> Content Hosts -> <host> -> Packages -> Applicable -> filter for "bind" -> select all -> Upgrade Selected


Actual results:
Tasks: Update package bind-libs-lite-9.9.4-50.el7_3.1.x86_64, bind-libs-lite-9.9.4-51.el7.x86_64, bind-libs-lite-9.9.4-51.el7_4.1.x86_64, bind-libs-lite-9.9.4-51.el7_4.2.x86_64, bind-libs-lite-9.9.4-61.el7.x86_64, bind-libs-lite-9.9.4-61.el7_5.1.x86_64, bind-libs-lite-9.9.4-72.el7.x86_64, bind-license-9.9.4-50.el7_3.1.noarch, bind-license-9.9.4-51.el7.noarch, bind-license-9.9.4-51.el7_4.1.noarch, bind-license-9.9.4-51.el7_4.2.noarch, bind-license-9.9.4-61.el7.noarch, bind-license-9.9.4-61.el7_5.1.noarch, bind-license-9.9.4-72.el7.noarch

Output:

32:bind-libs-lite-9.9.4-72.el7.x86_64
32:bind-license-9.9.4-72.el7.noarch

Errors:

PG::StringDataRightTruncation: ERROR:  value too long for type character varying(255)
: INSERT INTO "audits" ("auditable_id", "auditable_type", "user_id", "username", "action", "audited_changes", "version", "comment", "request_uuid", "created_at", "auditable_name") VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9, $10, $11) RETURNING "id"


Expected results:
Task should pass

Comment 2 Jan Hutař 2019-04-01 13:12:09 UTC
Created attachment 1550560 [details]
Satellite side traceback

Comment 3 Jan Hutař 2019-04-01 13:30:33 UTC
Same for errata upgrade action where I have selected 100 applicable errata - it was called "Install erratum RHBA-2019:40621, RHSA-2019:40408, RHBA-2019:40252, RHBA-2019:40194, RHBA-2019:40003, RHBA-2019:39731, RHBA-2019:39532, RHSA-2019:39433, RHSA-2019:39408, RHSA-2019:39393, RHBA-2019:39357, RHBA-2019:39356, RHEA-2019:39294, RHBA-2019:39259, RHBA-2019:0192, RHSA-2019:39170, RHBA-2019:39066, RHBA-2019:39054, RHBA-2019:0037, RHSA-2019:0049, RHSA-2018:3651, RHSA-2018:3665, RHBA-2018:3670, RHBA-2018:3664, RHBA-2018:3635, RHBA-2018:3543, RHBA-2018:3508, RHBA-2018:3454, RHBA-2018:3442, RHBA-2018:3098, RHBA-2018:3016, RHBA-2018:3286, RHBA-2018:3166, RHBA-2018:3072, RHBA-2018:3167, RHBA-2018:3106, RHBA-2018:3156, RHBA-2018:3013, RHBA-2018:3207, RHBA-2018:3172, RHBA-2018:3300, RHEA-2018:3097, RHBA-2018:3077, RHBA-2018:3245, RHBA-2018:3084, RHBA-2018:3340, RHBA-2018:3318, RHSA-2018:3041, RHBA-2018:3202, RHEA-2018:3149, RHBA-2018:3215, RHEA-2018:3135, RHBA-2018:3117, RHBA-2018:3045, RHBA-2018:3299, RHBA-2018:3141, RHSA-2018:3092, RHSA-2018:3107, RHBA-2018:3085, RHBA-2018:3088, RHBA-2018:3193, RHBA-2018:3184, RHBA-2018:3111, RHBA-2018:3192, RHSA-2018:3140, RHBA-2018:3119, RHBA-2018:3153, RHSA-2018:3221, RHBA-2018:3014, RHBA-2018:3074, RHBA-2018:3063, RHBA-2018:3240, RHBA-2018:3255, RHEA-2018:3114, RHBA-2018:3267, RHBA-2018:3093, RHEA-2018:3199, RHBA-2018:3120, RHBA-2018:3024, RHBA-2018:3264, RHBA-2018:3279, RHSA-2018:3059, RHBA-2018:3405, RHBA-2018:3297, RHBA-2018:3274, RHBA-2018:3131, RHBA-2018:3076, RHEA-2018:3130, RHBA-2018:3288, RHSA-2018:3157, RHBA-2018:3276, RHBA-2018:3230, RHBA-2018:3219, RHEA-2018:3250, RHBA-2018:3344, RHBA-2018:3203, RHBA-2018:3232, RHBA-2018:3252, RHBA-2018:3079, RHBA-2018:3314"

Comment 7 Marek Hulan 2019-04-05 14:31:26 UTC
Created redmine issue https://projects.theforeman.org/issues/26547 from this bug

Comment 11 Bryan Kearney 2019-04-09 18:06:29 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/26547 has been resolved.

Comment 13 Roman Plevka 2019-04-17 13:11:32 UTC
VERIFIED
on sat6.5.0-22

the task finishes successfully with the packages being updated:

Install erratum
User
admin
Started At
4/17/19 1:40 PM
Finished At
4/17/19 1:41 PM
Parameters
RHSA-2019:0194, RHBA-2018:3136, RHSA-2018:2570, RHBA-2018:0742, RHSA-2018:0102, RHBA-2017:3312 State
stopped
Result
success:

Output:
32:bind-libs-lite-9.9.4-73.el7_6.x86_64
32:bind-license-9.9.4-73.el7_6.noarch

Comment 15 errata-xmlrpc 2019-05-14 12:40:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.