Bug 1694814
| Summary: | Variable openshift_set_node_ip is deprecated in v3.10+ but this is not mentioned in inventory examples | |||
|---|---|---|---|---|
| Product: | OpenShift Container Platform | Reporter: | Radomir Ludva <rludva> | |
| Component: | Installer | Assignee: | Patrick Dillon <padillon> | |
| Installer sub component: | openshift-ansible | QA Contact: | Gaoyun Pei <gpei> | |
| Status: | CLOSED ERRATA | Docs Contact: | ||
| Severity: | medium | |||
| Priority: | unspecified | CC: | gpei | |
| Version: | 3.10.0 | |||
| Target Milestone: | --- | |||
| Target Release: | 3.10.z | |||
| Hardware: | Unspecified | |||
| OS: | Unspecified | |||
| Whiteboard: | ||||
| Fixed In Version: | Doc Type: | Bug Fix | ||
| Doc Text: |
Cause: openshift_set_node_ip was deprecated but still included in inventory example and some dead code.
Consequence: users might expect openshift_set_node_ip to set the ip address for an individual node but setting the inventory var would do nothing.
Fix: remove openshift_set_node_ip from example inventory and remove all related dead code. Also provide deprecated variable warning.
Result: users now understand this variable has been deprecated.
|
Story Points: | --- | |
| Clone Of: | ||||
| : | 1712488 (view as bug list) | Environment: | ||
| Last Closed: | 2019-06-27 16:41:12 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | ||||
| Bug Blocks: | 1712488 | |||
|
Description
Radomir Ludva
2019-04-01 18:35:29 UTC
Verify this bug with openshift-ansible-3.10.149-1.git.0.eb0262c.el7.noarch.rpm
# grep -r openshift_set_node_ip /usr/share/ansible/openshift-ansible/
/usr/share/ansible/openshift-ansible/roles/lib_utils/action_plugins/sanity_checks.py: ('openshift_set_node_ip', 'Deprecated: see documentation.'),
# grep -r openshift_set_node_ip /usr/share/doc/openshift-ansible-docs-3.10.149/
#
Once openshift_set_node_ip=true set in ansible inventory file, the install will fail as below:
TASK [Run variable sanity checks] **********************************************
Wednesday 12 June 2019 18:01:15 +0800 (0:00:00.579) 0:01:03.801 ********
fatal: [ec2-18-207-194-136.compute-1.amazonaws.com]: FAILED! => {"failed": true, "msg": "last_checked_host: ec2-18-207-194-136.compute-1.amazonaws.com, last_checked_var: openshift_master_manage_htpasswd;Found removed variables: openshift_set_node_ip is replaced by Deprecated: see documentation.; "}
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2019:1607 |