Bug 1694864 - failed to unmount: <nil>
Summary: failed to unmount: <nil>
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Ben Parees
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 21:31 UTC by Ben Parees
Modified: 2019-06-04 10:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:57 UTC

Description Ben Parees 2019-04-01 21:31:22 UTC
Description of problem:
Build logs show error message:

E0401 21:03:28.474030       1 source.go:416] failed to unmount: <nil>

But it does not appear to actually be an error and it always shows up when extracting content from an source input image.


How reproducible:
always

Steps to Reproduce:
1. run a build that extracts content from a source input image
2. look at the log

Actual results:
log shows:
ERROR: logging before flag.Parse: E0401 21:03:28.474030       1 source.go:416] failed to unmount: <nil>

(the logging before flag.Parse error was filed as a separate bug).


Expected results:
Message should not appear if there is no actual error.

Comment 1 Ben Parees 2019-04-01 21:33:16 UTC
https://github.com/openshift/builder/pull/57

Comment 3 wewang 2019-04-04 07:02:25 UTC
I can reproduce it in version:4.0.0-0.10: ERROR: logging before flag.Parse: E0404 06:42:39.275226       1 source.go:416] failed to unmount: <nil>, 
and it fixed in version
version:
4.0.0-0.ci-2019-04-04-014306
payload: registry.svc.ci.openshift.org/ocp/release@sha256:6fa9515010bc9d005fad4187dcf8e10fdd377c543cbbd98ac22914cdc77051c3

steps:
1. using https://raw.githubusercontent.com/openshift/origin/master/test/extended/testdata/builds/test-imagesource-buildconfig.yaml to create build  that extracts content from a source input image

Comment 5 errata-xmlrpc 2019-06-04 10:46:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.