Bug 1694871 - flag parse error in build logs
Summary: flag parse error in build logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.0
Assignee: Ben Parees
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-01 21:47 UTC by Ben Parees
Modified: 2019-06-04 10:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:57 UTC

Description Ben Parees 2019-04-01 21:47:33 UTC
Description of problem:
Various parts of the build log are showing flag parsing errors logging debug info:


ERROR: logging before flag.Parse: I0401 21:03:20.230571       1 builder.go:403] openshift-builder v4.0.0+8fc0166-21-dirty

ERROR: logging before flag.Parse: I0401 21:03:20.233739       1 builder.go:404] redacted build

ERROR: logging before flag.Parse: I0401 21:03:21.806110       1 source.go:154] Extracting image source from image 

ERROR: logging before flag.Parse: I0401 21:03:21.806175       1 dockerutil.go:125] Using Docker authentication configuration


How reproducible:
Always

Steps to Reproduce:
1. Run a build using build loglevel 5
2. grep the log output for "ERROR:"


Actual results:
debug output is prefixed with "ERROR: logging before flag.Parse:"


Expected results:
It should not be

Comment 1 Ben Parees 2019-04-02 14:36:34 UTC
https://github.com/openshift/builder/pull/58

Comment 3 wewang 2019-04-04 07:22:25 UTC
I can reproduce it in version:4.0.0-0.10,like error info:
ERROR: logging before flag.Parse: I0404 07:17:31.795408       1 sti.go:404] Locating docker auth for image image-registry.openshift-image-registry.svc:5000/wewang/imagesourceapp:latest and type PUSH_DOCKERCFG_PATH
ERROR: logging before flag.Parse: I0404 07:17:31.795465       1 sti.go:404] Getting docker auth in paths : [/var/run/secrets/openshift.io/push]
ERROR: logging before flag.Parse: I0404 07:17:31.795480       1 config.go:131] looking for config.json at /var/run/secrets/openshift.io/push/config.json
ERROR: logging before flag.Parse: I0404 07:17:31.795526       1 config.go:101] looking for .dockercfg at /var/run/secrets/openshift.io/push/.dockercfg
ERROR: logging before flag.Parse: I0404 07:17:31.795753       1 config.go:112] found .dockercfg at /var/run/secrets/openshift.io/push/.dockercfg
ERROR: logging before flag.Parse: I0404 07:17:31.795820       1 sti.go:404] Using serviceaccount user for Docker authentication for image image-registry.openshift-image-registry.svc:5000/wewang/imagesourceapp:latest
ERROR: logging before flag.Parse: I0404 07:17:31.795844       1 builder.go:303] Using provided push secret for pushing image-registry.openshift-image-registry.svc:5000/wewang/imagesourceapp:latest image


and it fixed in version
version:
4.0.0-0.ci-2019-04-04-014306
payload:
registry.svc.ci.openshift.org/ocp/release@sha256:6fa9515010bc9d005fad4187dcf8e10fdd377c543cbbd98ac22914cdc77051c3

Comment 5 errata-xmlrpc 2019-06-04 10:46:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.