Bug 1694905 - hardware-detect fails on ppc64le due to KeyError
Summary: hardware-detect fails on ppc64le due to KeyError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-hardware
Version: 15.0 (Stein)
Hardware: ppc64le
OS: Linux
high
high
Target Milestone: beta
: 15.0 (Stein)
Assignee: Tony Breeds
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1667964 1698308
TreeView+ depends on / blocked
 
Reported: 2019-04-02 02:42 UTC by Tony Breeds
Modified: 2019-09-26 10:49 UTC (History)
7 users (show)

Fixed In Version: python-hardware-0.20.1-0.20190411092051.4f5a02d.el8ost.src.rpm
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1698308 (view as bug list)
Environment:
Last Closed: 2019-09-21 11:21:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:23 UTC

Description Tony Breeds 2019-04-02 02:42:48 UTC
Description of problem:  hardware-detect is failing due to:

---
Vendor ID isn't in the lscpu output:

[root@ibm-p9wr-13 ~]# LANG=en_US.UTF-8 lscpu -x
Architecture:        ppc64le
Byte Order:          Little Endian
CPU(s):              144
On-line CPU(s) mask: ffffffffffffffffffffffffffffffffffff
Thread(s) per core:  4
Core(s) per socket:  18
Socket(s):           2
NUMA node(s):        6
Model:               2.2 (pvr 004e 1202)
Model name:          POWER9, altivec supported
CPU max MHz:         3800.0000
CPU min MHz:         2300.0000
L1d cache:           32K
L1i cache:           32K
L2 cache:            512K
L3 cache:            10240K
NUMA node0 CPU(s):   ffffffffffffffffff
NUMA node8 CPU(s):   ffffffffffffffffff000000000000000000
NUMA node252 CPU(s): 0
NUMA node253 CPU(s): 0
NUMA node254 CPU(s): 0
NUMA node255 CPU(s): 0
Which causes

[root@ibm-p9wr-13 ~]# hardware-detect
/bin/sh: cli64: command not found
Info: detect_areca: No controller found
Cannot find megacli on the system
read_smart: Reading S.M.A.R.T information on /dev/sdb
read_smart_ata: Found S.M.A.R.T information on /dev/sdb
read_smart: Reading S.M.A.R.T information on /dev/sda
read_smart_ata: Found S.M.A.R.T information on /dev/sda
connect: Connection refused 
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
connect: Connection refused
Failed to connect to lldpad - clif_open: Connection refused
Traceback (most recent call last):
  File "/usr/bin/hardware-detect", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python3.6/site-packages/hardware/detect.py", line 997, in main
    _main(options)
  File "/usr/lib/python3.6/site-packages/hardware/detect.py", line 924, in _main
    if not detect_system(hrdw):
  File "/usr/lib/python3.6/site-packages/hardware/detect.py", line 666, in detect_system
    get_cpus(hw_lst)
  File "/usr/lib/python3.6/site-packages/hardware/detect.py", line 725, in get_cpus
    processor), 'vendor', lscpu['Vendor ID']))
KeyError: 'Vendor ID'
[root@ibm-p9wr-13 ~]# 
---
Version-Release number of selected component (if applicable):
python3-hardware-0.20.0-0.20190328181231.b417976.el8ost.noarch



How reproducible:
100%


Steps to Reproduce:
1. Install python3-hardware on a ppc64le system running rhel-8
2. run hardware-detect

Comment 8 errata-xmlrpc 2019-09-21 11:21:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.