Bug 169496 - Dell Truemobile 1150 (Prism2/Orinoco) Mini-PCI Card Cannot Scan for Networks by Default Configuration
Dell Truemobile 1150 (Prism2/Orinoco) Mini-PCI Card Cannot Scan for Networks ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 17:07 EDT by Matt T. Proud
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 13:38:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt T. Proud 2005-09-28 17:07:37 EDT
Description of problem:
While I appreciate Fedora's automated networking and wireless configuration
scripts, there is one issue related to the scanning component of the Orinoco
driver that drives me nuts. The problem essentially is that the Orinoco driver
cannot scan for available wireless networks unless the network device has been
'ifconfig (device) up' prior to the scanning request. While this problem may
sound trivial, it certainly makes Fedora's automated network scripts useless
unless the device can be brought up before the scanning occurs. I have
experimented with this problem on other Linux installs, particularly Gentoo, and
I had to edit Gentoo's network handling scripts to 'ifconfig up' device prior to
scanning, so I know that this is a required solution.

The reason I post this bug here is that I do not know if it would be easy to
patch the Orinoco driver code such that it can scan without having the device be
'ifconfig up' prior to the scan. If this is possible, it would let the user
treat the wireless card practically like any other on any machine. As it stands,
it is very cumbersome to use this driver. Another potential solution would
relate to those who maintain the hardware configuration database: perhaps those
individuals could write a configuration exception that turns on the card prior
to scanning somewhere in the configuration scripts. I do not know whether this
is a possibility, but Fedora is the only distribution, as far as I know, that
has actually patched its kernel with newer Orinoco code, so this does not seem
too unreasonable to ask.

If it is at all helpful, I file for a similar bug report on the Orinoco's
development page:
http://savannah.nongnu.org/bugs/index.php?func=detailitem&item_id=14667

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1456

How reproducible:
Always

Steps to Reproduce:
1. With the Orinoco device off, perform iwlist (dev) scanning
2. Turn device on; run iwlist (dev) scanning
  
Actual results:
Note how in #1 that nothing is returned.
Note how in #2 something is returned.

Expected results:
Both cases should return something. This is fundamentally important if Fedora is
to handle Orinoco-based cards properly.

Additional info:
Comment 1 Dave Jones 2005-09-30 02:32:39 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 2 Dave Jones 2005-11-10 14:32:37 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 3 John W. Linville 2005-12-08 13:38:06 EST
Closed due to lack of response.  Please reopen when the requested information  
becomes available...thanks! 

Note You need to log in before you can comment on or make changes to this bug.