This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 1695 - color-vim won't colorize in an xterm
color-vim won't colorize in an xterm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
5.2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike Maher
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-03-23 13:36 EST by Steve Wills
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-23 17:24:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Wills 1999-03-23 13:36:41 EST
color-vim refuses to colorize if TERM is set to xterm. It
will only do so if TERM is set to rxvt. Since rxvt now sets
it TERM to xterm (which is a good thing, IMHO), I think
color-vim should colorize when TERM is set to xterm. As it
is now, I have to have this in my .vimrc:

if &term=="xterm"
     set term=rxvt
     set t_Co=8
     set t_Sb=^[4%dm
     set t_Sf=^[3%dm
endif

(In addition to these lines, which enable the colorizing:
syntax on
set nocompatible
)

I know this is the case in 5.2, it probably applies to 5.9
as well.
Comment 1 Bill Nottingham 1999-03-23 14:03:59 EST
color-vim uses ncurses. The default terminfo entry for
xterm says it doesn't support color, so color-vim believes it.
Comment 2 David Lawrence 1999-03-23 14:07:59 EST
I was unable to replicate this problem using vim-color-5.3-3. I set
the TERM to several choices such as xterm and rxvt with no change.
Comment 3 David Lawrence 1999-03-23 14:18:59 EST
There is a setting that has to be added to .vimrc for this to work
regardless of TERM type which should not have to be done according to
Steve and Bill. This is more of a change request.
Comment 4 Mike Maher 1999-03-23 17:24:59 EST
vimrc file fixed.
this may be a terminfo problem with ncurses.
a regular xterm does work with colorvim.

Note You need to log in before you can comment on or make changes to this bug.