Bug 169515 - httpd unable to deliver files larger than 2 GB
httpd unable to deliver files larger than 2 GB
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 03:26 EDT by Rainer Koenig
Modified: 2010-10-21 23:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 09:46:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2005-09-29 03:26:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

Description of problem:
While performing RHR tests I tried to put a Fedora Core 4 DVD iso image in the /ispec/files directory so that the RHR tests can use it. But httpd is not able to deliver this file (2.6 GB) to the client. The wget that is issued by the RHR test suite gets a "HTTP/403 Forbidden" when trying to download DVD.iso while it works fine when downloading CD.iso (which is just 700 MB).
On the server I get messages in the logfiles that say that the object is too big.
The other strange thing is that if I want to browse /ispec/files locally with my web browser I don't even see this big file. 
So it looks like that httpd is lacking of Large File Support.

Version-Release number of selected component (if applicable):
httpd-2.0.52-12.ent

How reproducible:
Always

Steps to Reproduce:
1. Install httpd out of the box
2. Install iSpec
3. Place a DVD.iso file in /var/www/html/ispec/files and try to get it from a client with wget
  

Actual Results:  As above: Client can't download, Browsing Directory doesn't show the file. As soon as the file size is below 2GB there is no problem.

Expected Results:  DVD.iso should be delivered in full size to client.

Additional info:

As a result of this I get CDROM test failures in RHR CDROM test since /tmp/DVD.iso is missing due to a faild tansfer from the httpd server.
Comment 1 Joe Orton 2005-10-04 09:46:14 EDT
Thanks for the report.

This issue cannot be fixed in an update to Red Hat Enterprise Linux 4 since it
requires binary interface changes.

The changes necessary to add LFS support to httpd (and the APR library) have
been committed upstream and are incorporated for the httpd-2.1.x/apr-1.x
releases; these will be made available in future versions of Red Hat Enterprise
Linux.

Note You need to log in before you can comment on or make changes to this bug.