Bug 169517 - SAN-Boot installation on BladeCenter LS20 fails
SAN-Boot installation on BladeCenter LS20 fails
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 04:54 EDT by Rainer Duffner
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 13:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Duffner 2005-09-29 04:54:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
I want to install RHEL4U1 on a dual-core dual Opteron Blade from IBM (BladeCenter LS20).
According to IBM, only local installs are possible:
http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=ibm&lndocid=MIGR-60579
Our blades don't have local disks, but connect to a HP EVA3000 SAN and boot from that.
According to information I have found on the net, to enable MPIO, one has to boot with "linux noprobe" and specify the qla2300-module with the "ql2xfailover=1" option - this works for RHEL3U5-i386, but when I do that with RHEL4U1, the keyboard isn't recognized anymore and I can't continue the installation.
This is because the BladeCenter uses an USB-keyboard (infact, everything that isn't SCSI is USB)

Is there a way to only not load the qla2300-module but all the rest?


Version-Release number of selected component (if applicable):
RHEL4U1-x86-64

How reproducible:
Always

Steps to Reproduce:
1. boot with linux=noprobe
2. watch as your keypresses are ignored
3. bang your head against blade-chassis
4. repeat..
  

Actual Results:  Nothing

Expected Results:  Keyboard detected

Additional info:

http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-60055&tempselected=5
http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=ibm&lndocid=MIGR-60579
Comment 1 Jeremy Katz 2005-10-03 13:49:55 EDT
'noprobe' does exactly what it sounds like and doesn't probe for _anything_ now.
 You probably want one of the more granular probing things such as "nostorage"
Comment 2 Rainer Duffner 2005-10-03 14:22:27 EDT
Well, I was looking for a list of options, but I couldn't find one.
In fact, I can't even find information about this command when I explicitly feed
google with it, except for mailinglist entries.

Additionally: does RHEL4U1 actually support the qla2xfailover=1 option or do I
have to compile my own kernel?




Note You need to log in before you can comment on or make changes to this bug.