Bug 1695176 - [rebase] CRD openapi must be re-enabled
Summary: [rebase] CRD openapi must be re-enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 4.1.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 15:55 UTC by David Eads
Modified: 2019-06-04 10:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:46:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:46:57 UTC

Description David Eads 2019-04-02 15:55:24 UTC
The rebase conflicted on openapi exposure for CRDs. You can find the missing commits in https://docs.google.com/spreadsheets/d/1Kw_hFCjDms8Mj1Fax3lTBs6znjueo_escesSuwcd6NY/edit#gid=0

Comment 1 Michal Fojtik 2019-04-05 12:37:26 UTC
PR: https://github.com/openshift/origin/pull/22464

Comment 2 Michal Fojtik 2019-04-12 08:01:58 UTC
*** Bug 1688638 has been marked as a duplicate of this bug. ***

Comment 3 Maciej Szulik 2019-04-12 10:14:36 UTC
The current PR is https://github.com/openshift/origin/pull/22524

Comment 4 Michal Fojtik 2019-04-12 13:47:06 UTC
This merged, OpenAPI should be now published for CRD resources.

Comment 5 Xingxing Xia 2019-04-17 10:31:26 UTC
In env of payload that does not include above fix, e.g. 4.0.0-0.nightly-2019-04-10-182914:
oc explain kubeapiservers
error: Couldn't find resource for "operator.openshift.io/v1, Kind=KubeAPIServer"

`oc get --raw /openapi/v2` does not contain content like in https://github.com/openshift/cluster-kube-apiserver-operator/blob/master/manifests/0000_10_kube-apiserver-operator_01_config.crd.yaml#L16 :

While in env of 4.1.0-0.ci-2019-04-16-214239, above issues don't occur:
oc explain kubeapiservers
KIND:     KubeAPIServer
VERSION:  operator.openshift.io/v1

DESCRIPTION:
     <empty>

FIELDS:
   apiVersion   <string>
     APIVersion defines the versioned schema of this representation of an
...

`oc get --raw /openapi/v2` CONTAINS content like in https://github.com/openshift/cluster-kube-apiserver-operator/blob/master/manifests/0000_10_kube-apiserver-operator_01_config.crd.yaml#L16

So bug is fixed. But bug needs be verified with nightly payload instead of ci payload, thus will check again when working nightly payload is available depending on bug 1700504 solved.

Comment 6 Maciej Szulik 2019-04-17 12:19:51 UTC
Xingxing these are tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1688638 feel free to add those that are missing there, still.

Comment 7 Xingxing Xia 2019-04-19 06:34:24 UTC
Verified in 4.1.0-0.nightly-2019-04-18-210657 .

Comment 9 errata-xmlrpc 2019-06-04 10:46:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.