Bug 1695324 - Unit test flake post 1.13 rebase
Summary: Unit test flake post 1.13 rebase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.1.0
Assignee: Jan Chaloupka
QA Contact: Jianwei Hou
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 20:12 UTC by Clayton Coleman
Modified: 2019-06-04 10:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:10 UTC

Comment 1 Jan Chaloupka 2019-04-02 20:39:44 UTC
Is it related to machineapi components or the cause is still unknown? Jusk asking since the bug is reported against Cloud Compute component.

Comment 2 Clayton Coleman 2019-04-03 18:40:43 UTC
Unknown.  It needs immediate triage and action.

Comment 3 Jan Chaloupka 2019-04-04 08:33:04 UTC
- github.com/openshift/origin/vendor/k8s.io/apiserver/pkg/storage/value/encrypt/envelope TestIntermittentConnectionLoss: looks like network issue due to (failed to create connection to unix socket: @kms-socket.sock, error: dial unix @kms-socket.sock: connect: connection refused)

- github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/cloudprovider/providers/aws TestCreateDisk: just wrong order of tags:
        Tags: [{
+          Key: "kubernetes.io/cluster/clusterid.test",
+          Value: "owned"
+        },{
           Key: "KubernetesCluster",
           Value: "clusterid.test"
-        },{
-          Key: "kubernetes.io/cluster/clusterid.test",
-          Value: "owned"
         }]

- github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/controller/podautoscaler TestLegacyScaleUpUnreadyLessScale: the test needs to be updated (k8s 1.13 client-go patch implementation in generated fake clients changed a bit, this might be related)

- github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubelet/cm/devicemanager TestNewManagerImplStartProbeMode:  (E0402 19:35:19.844615   13396 plugin_watcher.go:120] error stat file /tmp/volume/device_plugin355861278/device-plugin.sock failed: stat /tmp/volume/device_plugin355861278/device-plugin.sock: no such file or directory when handling create event: "/tmp/volume/device_plugin355861278/device-plugin.sock": CREATE)

Comment 4 Jan Chaloupka 2019-04-04 08:55:05 UTC
Potential fix for `github.com/openshift/origin/vendor/k8s.io/apiserver/pkg/storage/value/encrypt/envelope TestIntermittentConnectionLoss:`:  https://github.com/openshift/origin/pull/22463

Comment 5 Jan Chaloupka 2019-04-04 13:16:22 UTC
Fix for `github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/cloudprovider/providers/aws TestCreateDisk`: https://github.com/openshift/origin/pull/22477

Comment 6 Jan Chaloupka 2019-04-08 14:23:16 UTC
Fixing github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/controller/podautoscaler TestLegacyScaleUpUnreadyLessScale: https://github.com/openshift/origin/pull/22490

Comment 9 errata-xmlrpc 2019-06-04 10:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.