Bug 1695329 - Unit test flake post rebase: devicemanager TestNewManagerImplStartProbeMode [NEEDINFO]
Summary: Unit test flake post rebase: devicemanager TestNewManagerImplStartProbeMode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Fabio Bertinatto
QA Contact: Mike Fiedler
URL:
Whiteboard:
: 1698538 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 20:15 UTC by Clayton Coleman
Modified: 2019-06-04 10:47 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:00 UTC
Target Upstream Version:
fbertina: needinfo? (decarr)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:10 UTC

Description Clayton Coleman 2019-04-02 20:15:25 UTC
https://openshift-gce-devel.appspot.com/build/origin-ci-test/pr-logs/pull/22455/pull-ci-openshift-origin-master-unit/4554#githubcomopenshiftoriginvendork8siokubernetespkgkubeletcmdevicemanager-testnewmanagerimplstartprobemode

=== RUN   TestNewManagerImplStartProbeMode
2019/04 ...
				
=== RUN   TestNewManagerImplStartProbeMode
2019/04/02 19:35:19 Starting to serve on /tmp/volume/device_plugin355861278/device-plugin.sock
E0402 19:35:19.844615   13396 plugin_watcher.go:120] error stat file /tmp/volume/device_plugin355861278/device-plugin.sock failed: stat /tmp/volume/device_plugin355861278/device-plugin.sock: no such file or directory when handling create event: "/tmp/volume/device_plugin355861278/device-plugin.sock": CREATE
--- FAIL: TestNewManagerImplStartProbeMode (11.01s)
	assertions.go:254: 
			Error Trace:	manager_test.go:275
			            				manager_test.go:81
			Error:      	Received unexpected error:
			            	timeout on stopping watcher
			Test:       	TestNewManagerImplStartProbeMode

				

Failing very frequently post rebase

Comment 1 Matthew Wong 2019-04-02 20:50:15 UTC
fabio has a fix upstream being reviewed: https://github.com/kubernetes/kubernetes/pull/75110. upstream issue: https://github.com/kubernetes/kubernetes/issues/75097

I tested the fix locally and it doesn't seem to solve the problem totally, the test still fails frequently. I also tried testing it in combination with https://github.com/openshift/origin/pull/22055 and the test still fails.

Comment 2 Matthew Wong 2019-04-02 21:15:00 UTC
correction, we already have 22055 from the rebase so my patch did nothing. Will defer to fabio for progress on https://github.com/kubernetes/kubernetes/pull/75110

Comment 3 Clayton Coleman 2019-04-10 19:35:40 UTC
This is still failing and blocking the origin queue.  Moving back to 4.1.0

Comment 4 Clayton Coleman 2019-04-10 19:36:10 UTC
Moving this back to high because I'm disabling it because we couldn't get a fix in time https://github.com/openshift/origin/pull/22527

This will come back with the next rebase so leaving it on high.

Comment 5 Seth Jennings 2019-04-12 13:54:20 UTC
*** Bug 1698538 has been marked as a duplicate of this bug. ***

Comment 10 Fabio Bertinatto 2019-05-01 08:41:21 UTC
OpenShift patch merged: https://github.com/openshift/origin/pull/22715

Comment 14 errata-xmlrpc 2019-06-04 10:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.