Bug 1695353 - Can't get focus on new windows in GNOME on Xorg
Summary: Can't get focus on new windows in GNOME on Xorg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 30
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-02 21:18 UTC by Giuseppe
Modified: 2019-04-21 20:32 UTC (History)
8 users (show)

Fixed In Version: gnome-shell-3.32.1-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-21 20:32:57 UTC
Type: Bug


Attachments (Terms of Use)
system info (13.40 KB, text/plain)
2019-04-02 21:18 UTC, Giuseppe
no flags Details
Sysinfo (13.17 KB, text/plain)
2019-04-13 15:26 UTC, jos
no flags Details

Description Giuseppe 2019-04-02 21:18:25 UTC
Created attachment 1551160 [details]
system info

Description of problem:
When I launch any new application, I cannot get the focus on the newly opened window. My F30 installation is specular to my F29 one, both on bare hardware. I have installed the latest NVIDIA driver on both (418.56). However, while I get the expected behavior on F29, I don't get the same on F30: when I launch (e.g.) the gnome-terminal I cannot type anything unless I click on it first.

Version-Release number of selected component (if applicable):
mutter.x86_64         3.32.0-2.fc30                           
gnome-shell.x86_64    3.32.0-1.fc30                        
gnome-session.x86_64  3.32.0-1.fc30 

How reproducible:
Always on F30 when installed on bare metal. I don't have the same issue with the F30 WS Beta Live Image (Fedora-Workstation-Live-x86_64-30_Beta-1.8.iso).

Steps to Reproduce:
1. Install F30 on bare hardware
2. Install NVIDIA 418.56 drivers
3. Launch any application

Actual results:
Newly opened windows aren't active, cannot get the focus unless I click on them.

Expected results:
Focus on the newly opened windows.


Additional info:

Comment 1 Giuseppe 2019-04-03 00:12:57 UTC
Apparently the behavior described above does not depend on NVIDIA drivers. After a few tests I can conclude that the problem can be replicated with GNOME on Xorg and nouveau drivers as well, while GNOME on Wayland is not affected.

Comment 2 jos 2019-04-13 15:21:09 UTC
Same here, works on Wayland, but no focus on X11, using Nouveau or NVIDIA driver.

Comment 3 jos 2019-04-13 15:26:04 UTC
Created attachment 1554928 [details]
Sysinfo

Comment 4 Real Name 2019-04-18 18:40:25 UTC
Seems to be fixed already on 3.32.1. There are builds on koji if anyone wants to test.

Comment 5 William Makowski 2019-04-18 20:28:52 UTC
I agree, gnome-shell-3.32.1-1.fc30 from koji seems to fix the problem. Thanks for sharing news of the update.

Comment 6 Fedora Update System 2019-04-19 15:18:46 UTC
gnome-shell-3.32.1-1.fc30 gnome-shell-extensions-3.32.1-1.fc30 mutter-3.32.1-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2d456e35ff

Comment 7 Fedora Update System 2019-04-21 20:32:57 UTC
gnome-shell-3.32.1-1.fc30, gnome-shell-extensions-3.32.1-1.fc30, mutter-3.32.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.