Bug 1695494 - Logging EFK are not redeployed after changing resource limits and requests in ClusterLogging CR.
Summary: Logging EFK are not redeployed after changing resource limits and requests in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: ewolinet
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 08:33 UTC by Qiaoling Tang
Modified: 2019-06-04 10:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:10 UTC

Description Qiaoling Tang 2019-04-03 08:33:22 UTC
Description of problem:
Change resource limits and requests for CEFK in ClusterLogging CR, the elasticsearch, fluentd and kibana pods are not redeployed, the curator cronjob is not updated. 

The elasticsearch CR changed, but the deploy isn't.

$ oc get clusterlogging -o yaml
apiVersion: v1
items:
- apiVersion: logging.openshift.io/v1
  kind: ClusterLogging
  metadata:
    creationTimestamp: 2019-04-03T06:54:15Z
    generation: 1
    name: instance
    namespace: openshift-logging
    resourceVersion: "183763"
    selfLink: /apis/logging.openshift.io/v1/namespaces/openshift-logging/clusterloggings/instance
    uid: 4ba58e72-55dd-11e9-ab3c-0aefbeae65e8
  spec:
    collection:
      logs:
        fluentd:
          resources:
            limits:
              memory: 1Gi
            requests:
              cpu: 200m
              memory: 1Gi
        rsyslog:
          resources: null
        type: fluentd
    curation:
      curator:
        resources:
          limits:
            memory: 200Mi
          requests:
            cpu: 200m
            memory: 200Mi
        schedule: 30 3 * * *
      type: curator
    logStore:
      elasticsearch:
        nodeCount: 2
        redundancyPolicy: SingleRedundancy
        resources:
          limits:
            cpu: "1"
            memory: 4Gi
          requests:
            cpu: 500m
            memory: 1300Mi
        storage:
          size: 10Gi
          storageClassName: gp2
      type: elasticsearch
    managementState: Managed
    visualization:
      kibana:
        proxy:
          resources:
            limits:
              memory: 100Mi
            requests:
              cpu: 100m
              memory: 100Mi
        replicas: 1
        resources:
          limits:
            memory: 1Gi
          requests:
            cpu: 500m
            memory: 1Gi
      type: kibana

$ oc get elasticsearch -o yaml |grep resources -A 6
      resources:
        limits:
          cpu: "1"
          memory: 4Gi
        requests:
          cpu: 500m
          memory: 1300Mi

$ oc get deploy elasticsearch-cdm-ivvgu8p3-1 -o yaml |grep resources -A 6
        resources:
          limits:
            cpu: "1"
            memory: 4Gi
          requests:
            cpu: 200m
            memory: 1Gi

$ oc get deploy kibana -o yaml |grep resources -A 5
        resources:
          limits:
            memory: 736Mi
          requests:
            cpu: 100m
            memory: 736Mi
--
        resources:
          limits:
            memory: 256Mi
          requests:
            cpu: 100m
            memory: 256Mi

$ oc get ds fluentd -o yaml |grep resources -A 5
        resources:
          limits:
            memory: 736Mi
          requests:
            cpu: 100m
            memory: 736Mi

$ oc get cj curator -o yaml |grep resources -A 5
            resources:
              limits:
                memory: 256Mi
              requests:
                cpu: 100m
                memory: 256Mi


Version-Release number of selected component (if applicable):
quay.io/openshift/origin-elasticsearch-operator@sha256:f3e56412389727015e80b01420304f4736c58be20410fe67b9e4e676ba7cfd4a
quay.io/openshift/origin-cluster-logging-operator@sha256:abd72897d24101f17a390be3eb5e3f7abc1f00eb8bb905ccca66515a6c904433


How reproducible:
Always

Steps to Reproduce:
1. Deploy logging use cr: https://raw.githubusercontent.com/QiaolingTang/scripts-and-files/master/cr.yaml
2. change resource limits and requests in clusterlogging CR
3.

Actual results:


Expected results:


Additional info:

Comment 1 ewolinet 2019-04-03 20:58:26 UTC
https://github.com/openshift/elasticsearch-operator/pull/116

will also require a CLO change for the other components

Comment 4 Qiaoling Tang 2019-04-09 01:49:38 UTC
Verified in latest CLO and EO image:
quay.io/openshift/origin-cluster-logging-operator@sha256:949ee74661a3bac7d08084d01ce1375ff51a04f97d28ff59d7e35f49e5065a15
quay.io/openshift/origin-elasticsearch-operator@sha256:094754d814bc586f7d365f675ca7d005318ad8fe66278e467215abd3bdd94760

Comment 6 errata-xmlrpc 2019-06-04 10:47:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.