Bug 169550 - Error: Missing Dependency: apel-xemacs >= 10.5 is needed by package wl-xemacs
Error: Missing Dependency: apel-xemacs >= 10.5 is needed by package wl-xemacs
Product: Fedora
Classification: Fedora
Component: xemacs-sumo (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2005-09-29 12:01 EDT by Sam.
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-15 13:51:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sam. 2005-09-29 12:01:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
I can not update xemacs and it's utils because of a wrong dependency issue.

Error: Missing Dependency: apel-xemacs >= 10.5 is needed by package wl-xemacs

I have the higher version of apel-xemacs, but yum and rpm will not see it.

[root@maui1 Downloads]# rpm -q wl-xemacs
[root@maui1 Downloads]# rpm -q apel-xemacs

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run yum and rpm update

Actual Results:  Error: Missing Dependency: apel-xemacs >= 10.5 is needed by package wl-xemacs

Additional info:
Comment 1 Ville Skyttä 2005-09-29 13:29:45 EDT
(Cc'ing Jens, the FC wl maintainer, just a FYI.)  
The problem is that there's no separate apel-xemacs package any more, and   
xemacs-sumo provides only version 10.2.  Further, there's no wl-xemacs package   
in FC4 nor Extras for FC4.   
Unfortunately the best I can suggest is to manually remove wl-xemacs, and then   
try updating again.  "yum upgrade" (not "yum update") could also help, but I   
haven't tested that.  
Comment 2 Jens Petersen 2005-09-29 21:23:07 EDT
Hmm, ok - I plan to submit wl to Extras one day though...

It is strange that yum doesn't see the higher version of apel-xemacs.
Comment 3 Ville Skyttä 2005-10-03 01:25:00 EDT
It probably does see it, but xemacs-sumo has "Obsoletes: apel-xemacs < 10.6-6" 
for upgrades. 
Comment 4 Jens Petersen 2005-11-15 01:50:28 EST
ddskk requires apel-10.6 to build,
so I'm unable to build it currently in Extras.
Comment 5 Ville Skyttä 2005-11-15 13:51:47 EST
The ddskk specfile in CVS lists apel 10.2 as the minimum needed version...? 
More relevant discussion is in bug 162952, but Jens, please open a new 
separate bug and let's try to work it out there in case it's really 10.6 of 
apel that's required for ddskk and not 10.2.  It's not the same problem as 
this wl-xemacs one, so it's better discussed elsewhere. 
Comment 6 Jens Petersen 2005-11-15 21:44:24 EST
Ok, the ddskk.spec file is wrong then, because the build fails without 10.6.
It is not an upgrade problem, but it essentially amounts to the same thing.
Anyway let me open a new bug as you request.

Note You need to log in before you can comment on or make changes to this bug.