Bug 1695541 - [OSP15][Overcloud] Overcloud deployment failed on starting container-puppet-rabbit_init_tasks container - Failed to apply catalog: Cannot parse invalid user line
Summary: [OSP15][Overcloud] Overcloud deployment failed on starting container-puppet-r...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rabbitmq-server
Version: 15.0 (Stein)
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Michele Baldessari
QA Contact: pkomarov
URL:
Whiteboard:
: 1693855 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 10:14 UTC by Artem Hrechanychenko
Modified: 2019-09-26 10:49 UTC (History)
12 users (show)

Fixed In Version: rabbitmq-server-3.7.14-3.el8ost
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:21:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1822673 0 None None None 2019-04-03 11:44:18 UTC
OpenStack gerrit 649696 0 'None' MERGED Fix RabbitMQ locale for CentOS 7 (Puppet part) 2020-12-01 20:13:03 UTC
OpenStack gerrit 649697 0 'None' MERGED Fix RabbitMQ locale for CentOS 7 (t-h-t part) 2020-12-01 20:12:36 UTC
RDO 19963 0 None None None 2019-04-05 07:42:52 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:21:23 UTC

Internal Links: 1975519

Description Artem Hrechanychenko 2019-04-03 10:14:31 UTC
Description of problem:
OSP15 Compose - RHOS_TRUNK-15.0-RHEL-8-20190402.n.0 

3controller+1compute


"2019-04-03 09:17:03,843 ERROR: 44061 -- ['/usr/bin/podman', 'run', '--user', 'root', '--name', 'container-puppet-rabbit_in
it_tasks', '--env', 'PUPPET_TAGS=file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user', '--env', 'NAME=rabbit_init_tasks
', '--env', 'HOSTNAME=controller-0', '--env', 'NO_ARCHIVE=true', '--env', 'STEP=2', '--env', 'NET_HOST=true', '--log-driver', 'json
-file', '--volume', '/etc/localtime:/etc/localtime:ro', '--volume', '/tmp/tmpk_m20olk:/etc/config.pp:ro', '--volume', '/etc/puppet/
:/tmp/puppet-etc/:ro', '--volume', '/etc/pki/ca-trust/extracted:/etc/pki/ca-trust/extracted:ro', '--volume', '/etc/pki/tls/certs/ca
-bundle.crt:/etc/pki/tls/certs/ca-bundle.crt:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.trust.crt:/etc/pki/tls/certs/ca-bundle.
trust.crt:ro', '--volume', '/etc/pki/tls/cert.pem:/etc/pki/tls/cert.pem:ro', '--volume', '/var/lib/config-data:/var/lib/config-data
/:rw', '--volume', '/dev/log:/dev/log:rw', '--log-opt', 'path=/var/log/containers/stdouts/container-puppet-rabbit_init_tasks.log', 
'--security-opt', 'label=disable', '--volume', '/usr/share/openstack-puppet/modules/:/usr/share/openstack-puppet/modules/:ro', '--v
olume', '/var/lib/config-data/rabbitmq/etc/rabbitmq/:/etc/rabbitmq/:ro', '--volume', '/var/lib/rabbitmq:/var/lib/rabbitmq:z', '--en
trypoint', '/var/lib/container-puppet/container-puppet.sh', '--net', 'host', '--volume', '/etc/hosts:/etc/hosts:ro', '--volume', '/
var/lib/container-puppet/container-puppet.sh:/var/lib/container-puppet/container-puppet.sh:ro', '192.168.24.1:8787/rhosp15/openstac
k-rabbitmq:20190402.1'] run failed after + mkdir -p /etc/puppet",
        "+ '[' -n file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user ']'",
        "+ TAGS='--tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user'",
        "+ origin_of_time=/var/lib/config-data/rabbit_init_tasks.origin_of_time",
        "+ touch /var/lib/config-data/rabbit_init_tasks.origin_of_time",
        "+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/et
c/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user /etc/co
nfig.pp",
        "Error: /Stage[main]/Tripleo::Profile::Base::Rabbitmq/Rabbitmq_policy[ha-all@/]: Could not evaluate: cannot parse line from
 list_policies:warning: the VM is running with native name encoding of latin1 which may cause Elixir to malfunction as it expects u
tf8. Please ensure your locale is set to UTF-8 (which can be verified by running \"locale\" in your shell)",
        "Error: Failed to apply catalog: Cannot parse invalid user line: warning: the VM is running with native name encoding of la
tin1 which may cause Elixir to malfunction as it expects utf8. Please ensure your locale is set to UTF-8 (which can be verified by 
running \"locale\" in your shell)",
        "+ rc=1",
        "+ '[' 1 -ne 2 -a 1 -ne 0 ']'",
        "+ exit 1",
        " attempt(s): 1",
        "2019-04-03 09:17:03,843 WARNING: 44061 -- Retrying running container: rabbit_init_tasks",
        "2019-04-03 09:17:29,471 ERROR: 44061 -- ['/usr/bin/podman', 'start', '-a', 'container-puppet-rabbit_init_tasks'] run failed after + mkdir -p /etc/puppet",
        " attempt(s): 2",
        "2019-04-03 09:17:29,472 WARNING: 44061 -- Retrying running container: rabbit_init_tasks",
        "2019-04-03 09:17:54,019 ERROR: 44061 -- ['/usr/bin/podman', 'start', '-a', 'container-puppet-rabbit_init_tasks'] run failed after + mkdir -p /etc/puppet",
        " attempt(s): 3",
        "2019-04-03 09:17:54,019 WARNING: 44061 -- Retrying running container: rabbit_init_tasks",
 "2019-04-03 09:17:54,019 WARNING: 44061 -- Retrying running container: rabbit_init_tasks",
        "2019-04-03 09:17:54,019 ERROR: 44061 -- Failed running container for rabbit_init_tasks",
        "2019-04-03 09:17:54,019 INFO: 44061 -- Finished processing puppet configs for rabbit_init_tasks",
        "2019-04-03 09:17:54,020 ERROR: 44059 -- ERROR configuring rabbit_init_tasks"
    ]
}
skipping: [controller-1] => {}
skipping: [controller-2] => {}
skipping: [compute-0] => {}

NO MORE HOSTS LEFT *************************************************************

PLAY RECAP *********************************************************************
compute-0                  : ok=154  changed=74   unreachable=0    failed=0   
controller-0               : ok=216  changed=127  unreachable=0    failed=1   
controller-1               : ok=213  changed=126  unreachable=0    failed=0   
controller-2               : ok=213  changed=126  unreachable=0    failed=0   
undercloud                 : ok=11   changed=8    unreachable=0    failed=0   

Wednesday 03 April 2019  05:17:54 -0400 (0:00:00.191)       0:21:08.542 ******* 
=============================================================================== 
Exception occured while running the command
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/command.py", line 30, in run
    super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/osc_lib/command/command.py", line 41, in run
    return super(Command, self).run(parsed_args)
  File "/usr/lib/python3.6/site-packages/cliff/command.py", line 184, in run
    return_code = self.take_action(parsed_args) or 0
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/overcloud_deploy.py", line 949, in take_action
    verbosity=self.app_args.verbose_level)
  File "/usr/lib/python3.6/site-packages/tripleoclient/workflows/deployment.py", line 327, in config_download
    raise exceptions.DeploymentError("Overcloud configuration failed.")
tripleoclient.exceptions.DeploymentError: Overcloud configuration failed.
Overcloud configuration failed.

Ansible failed, check log at /var/lib/mistral/overcloud/ansible.log.



controller-0:

21f749fc3a80  192.168.24.1:8787/rhosp15/openstack-rabbitmq:20190402.1            /var/lib/containe...  About an hour ago  Exited (1) About an hour ago         container-puppet-rabbit_init_tasks

+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/etc/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user /etc/config.pp
Warning: /etc/puppet/hiera.yaml: Use of 'hiera.yaml' version 3 is deprecated. It should be converted to version 5
   (file: /etc/puppet/hiera.yaml)
Warning: Undefined variable '::deploy_config_name'; \n   (file & line not available)
Warning: The function 'hiera' is deprecated in favor of using 'lookup'. See https://puppet.com/docs/puppet/5.5/deprecated_language.html\n   (file & line not available)
Notice: Compiled catalog for controller-0.localdomain in environment production in 0.32 seconds
Error: /Stage[main]/Tripleo::Profile::Base::Rabbitmq/Rabbitmq_policy[ha-all@/]: Could not evaluate: cannot parse line from list_policies:warning: the VM is running with native name encoding of latin1 which may cause Elixir to malfunction as it expects utf8. Please ensure your locale is set to UTF-8 (which can be verified by running "locale" in your shell)
Error: Failed to apply catalog: Cannot parse invalid user line: warning: the VM is running with native name encoding of latin1 which may cause Elixir to malfunction as it expects utf8. Please ensure your locale is set to UTF-8 (which can be verified by running "locale" in your shell)
Changes:
Events:
          Failure: 1
            Total: 1
Resources:
           Failed: 1
      Out of sync: 1
          Skipped: 5
            Total: 15
Time:
             File: 0.00
   Config retrieval: 0.40
   Rabbitmq policy: 1.13
         Last run: 1554283070
            Total: 2.39
Version:
           Config: 1554283068
           Puppet: 5.5.6
+ rc=1
+ set -e
+ '[' 1 -ne 2 -a 1 -ne 0 ']'
+ exit 1


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Artem Hrechanychenko 2019-04-03 10:20:59 UTC
Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190402.n.0

How reproducible:


Steps to Reproduce:
1.Deploy OSP15 Overcloud

Actual results:
Failed "Run container-puppet tasks (bootstrap tasks) for step 2]"
"2019-04-03 09:17:03,843 ERROR: 44061 -- ['/usr/bin/podman', 'run', '--user', 'root', '--name', 'container-puppet-rabbit_init_tasks', '--env', 'PUPPET_TAGS=file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user', '--env', 'NAME=rabbit_init_tasks', '--env', 'HOSTNAME=controller-0', '--env', 'NO_ARCHIVE=true', '--env', 'STEP=2', '--env', 'NET_HOST=true', '--log-driver', 'json-file', '--volume', '/etc/localtime:/etc/localtime:ro', '--volume', '/tmp/tmpk_m20olk:/etc/config.pp:ro', '--volume', '/etc/puppet/:/tmp/puppet-etc/:ro', '--volume', '/etc/pki/ca-trust/extracted:/etc/pki/ca-trust/extracted:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.crt:/etc/pki/tls/certs/ca-bundle.crt:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.trust.crt:/etc/pki/tls/certs/ca-bundle.trust.crt:ro', '--volume', '/etc/pki/tls/cert.pem:/etc/pki/tls/cert.pem:ro', '--volume', '/var/lib/config-data:/var/lib/config-data/:rw', '--volume', '/dev/log:/dev/log:rw', '--log-opt', 'path=/var/log/containers/stdouts/container-puppet-rabbit_init_tasks.log', '--security-opt', 'label=disable', '--volume', '/usr/share/openstack-puppet/modules/:/usr/share/openstack-puppet/modules/:ro', '--volume', '/var/lib/config-data/rabbitmq/etc/rabbitmq/:/etc/rabbitmq/:ro', '--volume', '/var/lib/rabbitmq:/var/lib/rabbitmq:z', '--entrypoint', '/var/lib/container-puppet/container-puppet.sh', '--net', 'host', '--volume', '/etc/hosts:/etc/hosts:ro', '--volume', '/var/lib/container-puppet/container-puppet.sh:/var/lib/container-puppet/container-puppet.sh:ro', '192.168.24.1:8787/rhosp15/openstack-rabbitmq:20190402.1'] run failed after + mkdir -p /etc/puppet",
        "+ '[' -n file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user ']'",
        "+ TAGS='--tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user'",
        "+ origin_of_time=/var/lib/config-data/rabbit_init_tasks.origin_of_time",
        "+ touch /var/lib/config-data/rabbit_init_tasks.origin_of_time",
        "+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/etc/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user /etc/config.pp",
        "Error: /Stage[main]/Tripleo::Profile::Base::Rabbitmq/Rabbitmq_policy[ha-all@/]: Could not evaluate: cannot parse line from list_policies:warning: the VM is running with native name encoding of latin1 which may cause Elixir to malfunction as it expects utf8. Please ensure your locale is set to UTF-8 (which can be verified by running \"locale\" in your shell)",
        "Error: Failed to apply catalog: Cannot parse invalid user line: warning: the VM is running with native name encoding of latin1 which may cause Elixir to malfunction as it expects utf8. Please ensure your locale is set to UTF-8 (which can be verified by running \"locale\" in your shell)",

Expected results:
Passed

Additional info:

Comment 5 Artem Hrechanychenko 2019-04-08 12:03:42 UTC
the same issue appears in undercloud & overcloud redeployment

Comment 7 Michele Baldessari 2019-04-09 07:09:45 UTC
*** Bug 1693855 has been marked as a duplicate of this bug. ***

Comment 10 Artem Hrechanychenko 2019-04-18 09:30:47 UTC
Issue still exist for OC and UC re-deployment

TASK [Debug output for task: Run container-puppet tasks (bootstrap tasks) for step 2] ***
fatal: [undercloud-0]: FAILED! => {
    "failed_when_result": true,
    "outputs.stdout_lines | default([]) | union(outputs.stderr_lines | default([]))": [
        "2019-04-18 09:00:32,148 INFO: 83458 -- Running container-puppet",
        "2019-04-18 09:00:32,149 INFO: 83458 -- Service compilation completed.",
        "2019-04-18 09:00:32,149 INFO: 83458 -- Starting multiprocess configuration steps.  Using 4 processes.",
        "2019-04-18 09:00:32,158 INFO: 83460 -- Starting configuration of mysql_init_tasks using image 192.168.24.1:8787/rhosp15/openstack-mariadb:20190411.1",
        "2019-04-18 09:00:32,158 INFO: 83461 -- Starting configuration of rabbit_init_tasks using image 192.168.24.1:8787/rhosp15/openstack-rabbitmq:20190411.1",
        "2019-04-18 09:00:32,325 INFO: 83460 -- Removing container: container-puppet-mysql_init_tasks",
        "2019-04-18 09:00:32,332 INFO: 83461 -- Removing container: container-puppet-rabbit_init_tasks",
        "2019-04-18 09:00:32,645 INFO: 83460 -- Image already exists: 192.168.24.1:8787/rhosp15/openstack-mariadb:20190411.1",
        "2019-04-18 09:00:32,654 INFO: 83461 -- Image already exists: 192.168.24.1:8787/rhosp15/openstack-rabbitmq:20190411.1",
        "2019-04-18 09:00:49,474 WARNING: 83460 -- + mkdir -p /etc/puppet",
        "+ cp -dR /tmp/puppet-etc/auth.conf /tmp/puppet-etc/hiera.yaml /tmp/puppet-etc/hieradata /tmp/puppet-etc/modules /tmp/puppet-etc/puppet.conf /tmp/puppet-etc/ssl /etc/puppet",
        "+ rm -Rf /etc/puppet/ssl",
        "+ echo '{\"step\": 2}'",
        "+ TAGS=",
        "+ '[' -n file,file_line,concat,augeas,cron,mysql_database,mysql_grant,mysql_user ']'",
        "+ TAGS='--tags file,file_line,concat,augeas,cron,mysql_database,mysql_grant,mysql_user'",
        "+ CHECK_MODE=",
        "+ '[' -d /tmp/puppet-check-mode ']'",
        "+ origin_of_time=/var/lib/config-data/mysql_init_tasks.origin_of_time",
        "+ touch /var/lib/config-data/mysql_init_tasks.origin_of_time",
        "+ sync",
        "+ export NET_HOST=true",
        "+ NET_HOST=true",
        "+ set +e",
        "+ '[' true == false ']'",
        "+ export FACTER_deployment_type=containers",
        "+ FACTER_deployment_type=containers",
        "++ tr '[:upper:]' '[:lower:]'",
        "++ cat /sys/class/dmi/id/product_uuid",
        "+ export FACTER_uuid=917b3387-60ac-4a8f-b462-067a493e11ae",
        "+ FACTER_uuid=917b3387-60ac-4a8f-b462-067a493e11ae",
        "+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/etc/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,mysql_database,mysql_grant,mysql_user /etc/config.pp",
        "Warning: /etc/puppet/hiera.yaml: Use of 'hiera.yaml' version 3 is deprecated. It should be converted to version 5",
        "   (file: /etc/puppet/hiera.yaml)",
        "Warning: Undefined variable '::deploy_config_name'; \\n   (file & line not available)",
        "Warning: The function 'hiera' is deprecated in favor of using 'lookup'. See https://puppet.com/docs/puppet/5.5/deprecated_language.html\\n   (file & line not available)",
        "Warning: This method is deprecated, please use the stdlib validate_legacy function,",
        "                    with Stdlib::Compat::Hash. There is further documentation for validate_legacy function in the README. at [\"/etc/puppet/modules/tripleo/manifests/profile/base/database/mysql.pp\", 119]:[\"/etc/config.pp\", 2]",
        "   (location: /etc/puppet/modules/stdlib/lib/puppet/functions/deprecation.rb:28:in `deprecation')",
        "Warning: ModuleLoader: module 'mysql' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: ModuleLoader: module 'glance' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: ModuleLoader: module 'heat' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: ModuleLoader: module 'ironic' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: ModuleLoader: module 'keystone' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: ModuleLoader: module 'neutron' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: ModuleLoader: module 'nova' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "Warning: Scope(Class[Nova::Db::Mysql_placement]): nova::db::mysql_placement is deprecated and will be removed in a future release",
        "Warning: ModuleLoader: module 'openstacklib' has unresolved dependencies - it will only see those that are resolved. Use 'puppet module list --tree' to see information about modules\\n   (file & line not available)",
        "+ rc=2",
        "+ set -e",
        "+ '[' 2 -ne 2 -a 2 -ne 0 ']'",
        "+ '[' -z true ']'",
        "",
        "2019-04-18 09:00:49,474 INFO: 83460 -- Removing container: container-puppet-mysql_init_tasks",
        "2019-04-18 09:00:49,634 INFO: 83460 -- Finished processing puppet configs for mysql_init_tasks",
        "2019-04-18 09:00:52,813 ERROR: 83461 -- ['/usr/bin/podman', 'run', '--user', 'root', '--name', 'container-puppet-rabbit_init_tasks', '--env', 'PUPPET_TAGS=file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user', '--env', 'NAME=rabbit_init_tasks', '--env', 'HOSTNAME=undercloud-0', '--env', 'NO_ARCHIVE=true', '--env', 'STEP=2', '--env', 'NET_HOST=true', '--log-driver', 'json-file', '--volume', '/etc/localtime:/etc/localtime:ro', '--volume', '/tmp/tmpg7kc036h:/etc/config.pp:ro', '--volume', '/etc/puppet/:/tmp/puppet-etc/:ro', '--volume', '/etc/pki/ca-trust/extracted:/etc/pki/ca-trust/extracted:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.crt:/etc/pki/tls/certs/ca-bundle.crt:ro', '--volume', '/etc/pki/tls/certs/ca-bundle.trust.crt:/etc/pki/tls/certs/ca-bundle.trust.crt:ro', '--volume', '/etc/pki/tls/cert.pem:/etc/pki/tls/cert.pem:ro', '--volume', '/var/lib/config-data:/var/lib/config-data/:rw', '--volume', '/dev/log:/dev/log:rw', '--log-opt', 'path=/var/log/containers/stdouts/container-puppet-rabbit_init_tasks.log', '--security-opt', 'label=disable', '--volume', '/usr/share/openstack-puppet/modules/:/usr/share/openstack-puppet/modules/:ro', '--volume', '/var/lib/config-data/rabbitmq/etc/rabbitmq/:/etc/rabbitmq/:ro', '--volume', '/var/lib/rabbitmq:/var/lib/rabbitmq:z', '--entrypoint', '/var/lib/container-puppet/container-puppet.sh', '--net', 'host', '--volume', '/etc/hosts:/etc/hosts:ro', '--volume', '/var/lib/container-puppet/container-puppet.sh:/var/lib/container-puppet/container-puppet.sh:ro', '192.168.24.1:8787/rhosp15/openstack-rabbitmq:20190411.1'] run failed after + mkdir -p /etc/puppet",
        "+ '[' -n file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user ']'",
        "+ TAGS='--tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user'",
        "+ origin_of_time=/var/lib/config-data/rabbit_init_tasks.origin_of_time",
        "+ touch /var/lib/config-data/rabbit_init_tasks.origin_of_time",
        "+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/etc/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,rabbitmq_policy,rabbitmq_user /etc/config.pp",
        "Error: Failed to apply catalog: Cannot parse invalid user line: warning: Elixir is running in a system with a different endianness than the one its source code was compiled in. Please make sure Elixir and all source files were compiled in a machine with the same endianness as the current one: little",
        "+ rc=1",
        "+ '[' 1 -ne 2 -a 1 -ne 0 ']'",
        "+ exit 1",
        " attempt(s): 1",
        "2019-04-18 09:00:52,814 WARNING: 83461 -- Retrying running container: rabbit_init_tasks",
        "2019-04-18 09:01:12,496 ERROR: 83461 -- ['/usr/bin/podman', 'start', '-a', 'container-puppet-rabbit_init_tasks'] run failed after + mkdir -p /etc/puppet",
        " attempt(s): 2",
        "2019-04-18 09:01:12,496 WARNING: 83461 -- Retrying running container: rabbit_init_tasks",
        "2019-04-18 09:01:31,923 ERROR: 83461 -- ['/usr/bin/podman', 'start', '-a', 'container-puppet-rabbit_init_tasks'] run failed after + mkdir -p /etc/puppet",
        " attempt(s): 3",
        "2019-04-18 09:01:31,924 WARNING: 83461 -- Retrying running container: rabbit_init_tasks",
        "2019-04-18 09:01:31,924 ERROR: 83461 -- Failed running container for rabbit_init_tasks",
        "2019-04-18 09:01:31,924 INFO: 83461 -- Finished processing puppet configs for rabbit_init_tasks",
        "2019-04-18 09:01:31,925 ERROR: 83458 -- ERROR configuring rabbit_init_tasks"
    ]
}

NO MORE HOSTS LEFT *************************************************************

PLAY RECAP *********************************************************************
undercloud-0               : ok=258  changed=91   unreachable=0    failed=1    skipped=225  rescued=0    ignored=1

Exception: Deployment failed
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/tripleoclient/v1/tripleo_deploy.py", line 1256, in _standalone_deploy
    raise exceptions.DeploymentError('Deployment failed')
tripleoclient.exceptions.DeploymentError: Deployment failed
None
Install artifact is located at /home/stack/undercloud-install-20190418090132.tar.bzip2
The heat stack undercloud virtual state/action is reset to CREATE. Use "--force-stack-update" to set it forcefully to UPDATE
Removing the stack virtual update mark file /var/lib/tripleo-heat-installer/update_mark_undercloud

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Deployment Failed!

Comment 18 pkomarov 2019-06-04 17:58:14 UTC
Verified , on_qa puddle passed deployment : 
https://rhos-ci-staging-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/DFG-pidone-updates-15_director-rhel-virthost-3cont_2comp-ipv4-geneve-sanity/5/

All versions are in the puddle : 
[stack@undercloud-0 ~]$ rhos-release -L
Installed repositories (rhel-8.0):
  15
  ceph-4
  ceph-osd-4
  rhel-8.0
[stack@undercloud-0 ~]$ cat core_puddle_version 
RHOS_TRUNK-15.0-RHEL-8-20190523.n.1[stack@undercloud-0 ~]$ ansible controller-0 -mshell -b -a "podman exec \$(sue -q) rpm -qa|grep rabbitmq-server"

controller-0 | CHANGED | rc=0 >>
rabbitmq-server-3.7.15-1.el8ost.x86_64

Comment 22 errata-xmlrpc 2019-09-21 11:21:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.