Bug 1695550 - [marketplace]Some opsrc can't be detected after the cluster upgrade
Summary: [marketplace]Some opsrc can't be detected after the cluster upgrade
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: lgallett
QA Contact: Fan Jia
URL:
Whiteboard:
: 1711259 (view as bug list)
Depends On:
Blocks: 1716524
TreeView+ depends on / blocked
 
Reported: 2019-04-03 10:29 UTC by Fan Jia
Modified: 2019-09-25 02:13 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1716524 (view as bug list)
Environment:
Last Closed: 2019-08-27 18:25:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Kevin Rizza 2019-04-03 18:51:59 UTC
Is it possible to get a full log of the marketplace-operator?

Comment 2 Kevin Rizza 2019-04-03 18:52:44 UTC
Also, how frequently is this reproducible? I still haven't been able to reproduce it.

Comment 3 aravindh 2019-04-03 18:57:59 UTC
Given how difficult it has been for us to reproduce this, is this really a beta blocker?

Comment 5 Fan Jia 2019-04-04 02:10:55 UTC
(In reply to Kevin Rizza from comment #1)
> Is it possible to get a full log of the marketplace-operator?

kevin, the full log: http://pastebin.test.redhat.com/749435

Comment 7 aravindh 2019-05-17 17:18:23 UTC
*** Bug 1711259 has been marked as a duplicate of this bug. ***

Comment 9 Fan Jia 2019-05-29 02:55:19 UTC
For CatalogSourceConfigs that are connected to OperatorSources, the hourly sync will fix it. Can recreate the operatorsource if the according csc's packagelist is still empty 1 hour later (can delete the default operatorsource "redhat-operators" "certified-operators" "community-operators" and they will recover 15 minutes).

Comment 10 lgallett 2019-05-29 13:59:10 UTC
PR to fix this issue is up https://github.com/operator-framework/operator-marketplace/pull/191


Note You need to log in before you can comment on or make changes to this bug.