Bug 1695679 (CVE-2019-5953) - CVE-2019-5953 wget: "do_conversion()" heap-based buffer overflow vulnerability
Summary: CVE-2019-5953 wget: "do_conversion()" heap-based buffer overflow vulnerability
Status: NEW
Alias: CVE-2019-5953
Product: Security Response
Classification: Other
Component: vulnerability   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
Whiteboard: impact=important,public=20190403,repo...
Keywords: Security
Depends On: 1696733 1696734 1696735 1696736 1696738
Blocks: 1695681
TreeView+ depends on / blocked
Reported: 2019-04-03 15:20 UTC by Pedro Sampaio
Modified: 2019-04-25 13:11 UTC (History)
3 users (show)

Fixed In Version: wget 1.20.3
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Pedro Sampaio 2019-04-03 15:20:02 UTC
A buffer overflow vulnerability was found in GNU Wget 1.20.1 and earlier. An attacker may be able to cause a denial-of-service (DoS) or may execute an arbitrary code.



Comment 3 Stefan Cornelius 2019-04-05 14:25:08 UTC

This issue did not affect the versions of wget as shipped with Red Hat Enterprise Linux 5 and 6.

This issue affects the versions of wget as shipped with Red Hat Enterprise Linux 7.

Comment 4 Stefan Cornelius 2019-04-05 14:25:45 UTC
Created wget tracking bugs for this issue:

Affects: fedora-all [bug 1696738]

Comment 6 Marian Rehak 2019-04-09 06:57:23 UTC
The new buffer overflow bug fixed upstream in versions 1.20.2 and 1.20.3

Comment 8 Stefan Cornelius 2019-04-25 13:11:11 UTC
The vulnerability is a heap-based buffer overflow within the "do_conversion()" function in src/iri.c when processing Internationalized Resource Identifiers. An attacker can exploit this vulnerability to cause a crash and, potentially, execute arbitrary code by, for example, tricking a user into recursively downloading a specially crafted website.

Upstream announced a fix for this issue as part of version 1.20.2. However, this version did not actually contain the necessary code changes, thus leaving version 1.20.2 vulnerable. Version 1.20.3 fixed this.

Note You need to log in before you can comment on or make changes to this bug.