Bug 1695860 - Remove static name parameters from the AWS CloudFormation templates
Summary: Remove static name parameters from the AWS CloudFormation templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: x86_64
OS: Other
high
urgent
Target Milestone: ---
: 4.1.0
Assignee: Stephen Cuppett
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 19:56 UTC by Kathryn Alexander
Modified: 2019-06-04 10:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:11 UTC

Description Kathryn Alexander 2019-04-03 19:56:48 UTC
Description of problem: Several of the objects in the 02_cluster_infra.yaml template contain static name parameters that make it impossible to deploy another stack without modifying the template.


How reproducible:

Steps to Reproduce:
1. Deploy the infra template.
2. Deploy the infra template again to a different stack.

Actual results:
Stack deployment fails and is rolled back because the InternalServiceTargetGroup already exists:


            "StackId": "arn:aws:cloudformation:us-east-1:269733383066:stack/kalexanddns1/36628930-563a-11e9-8556-0ee7d31f28a0",
            "EventId": "InternalServiceTargetGroup-CREATE_FAILED-2019-04-03T17:59:28.072Z",
            "StackName": "kalexanddns1",
            "LogicalResourceId": "InternalServiceTargetGroup",
            "PhysicalResourceId": "",
            "ResourceType": "AWS::ElasticLoadBalancingV2::TargetGroup",
            "Timestamp": "2019-04-03T17:59:28.072Z",
            "ResourceStatus": "CREATE_FAILED",
            "ResourceStatusReason": "InternalServiceTargetGroup already exists in stack arn:aws:cloudformation:us-east-1:269733383066:stack/KatherineClusterInfra/aec15820-4a4b-11e9-afb3-0e7f598ae3ee",
            "ResourceProperties": "{\"VpcId\":\"vpc-005b5b485342f7bba\",\"Port\":\"22623\",\"TargetType\":\"ip\",\"TargetGroupAttributes\":[{\"Value\":\"60\",\"Key\":\"deregistration_delay.timeout_seconds\"}],\"Protocol\":\"TCP\",\"Name\":\"InternalServiceTargetGroup\"}"


Stephen has a fix for the template.

Comment 1 Stephen Cuppett 2019-04-03 20:12:45 UTC
https://github.com/openshift/installer/pull/1527

Comment 2 Johnny Liu 2019-04-04 08:21:07 UTC
The PR is merged, so move this bug to ON_QA.

Comment 3 Johnny Liu 2019-04-04 08:24:27 UTC
Verified this bug with latest template, and passed.

Now target group are created with some random string in their name, when I am using 'jialiuuuuu2' as cluster name, those target group would something like:
jiali-Exter-R8T1T135WFIA
jiali-Inter-1J81P3GSGHXLM
jiali-Inter-1SGXWMUVV1F0Q

Comment 5 errata-xmlrpc 2019-06-04 10:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.