This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 169589 - Why the heck was kpackage removed
Why the heck was kpackage removed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kdeadmin (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 19:02 EDT by Jonathan Amir
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 13:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Amir 2005-09-29 19:02:15 EDT
Description of problem:
kpackage seems to be deliberately removed from kdeadmin. For the life of me, I
don't understand why you do it. It is a superb product, much better than the
add/remove program provided by fedora.
My apologies if this is a dupe. I did a quick search for kdeadmin and kpackage
and found nothing. Searching google didn't give me too much info either.

It is very disappointing that you do that. Please put kpackage back and try not
to mess with gnome and kde so much.

Version-Release number of selected component (if applicable):


How reproducible:
Install FC4 :)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
kpackage is missing

Expected results:
I want kpackage

Additional info:
Comment 1 Petr Rockai 2005-10-03 08:58:06 EDT
Kpackage is rather buggy and very unmaintained.  
  
You are of course free to compile it yourself or download elsewhere (or even     
propose inclusion in fedora extras), unless we manage to sort this out 
somehow. However note, that we have little manpower and kpackage doesn't 
really get too much priority. 
 
Than, what do you think? Kpackage was disabled ages ago, due to rpm api 
changing. I am not sure if it even compiles nowadays. If you think it is worth 
it, i can try and see if we can get it back. 
Comment 2 Ngo Than 2005-10-04 04:29:35 EDT
i see the same from my side. I don't think it's worth to add it back. 
Comment 3 Steve 2006-02-12 20:14:45 EST
download kdeadmin-3.5.1-0.1.fc4.src.rpm

# diff kdeadmin.spec.orig kdeadmin.spec
7c7
< %define kpackage 0
---
> %define kpackage 1
287,288c287,288
<   mv $RPM_BUILD_ROOT/usr/bin/kpackager $RPM_BUILD_ROOT/usr/sbin
<   ln -s consolehelper $RPM_BUILD_ROOT/usr/bin/kpackager
---
>   mv $RPM_BUILD_ROOT/usr/bin/kpackage $RPM_BUILD_ROOT/usr/sbin
>   ln -s consolehelper $RPM_BUILD_ROOT/usr/bin/kpackage
375c375
< %{_datadir}/mimelnk/application/x-debian-package.desktop
---
> #%{_datadir}/mimelnk/application/x-debian-package.desktop

# rpmbuild -bb kdeadmin.spec
# rpm -Uvh --force /usr/src/redhat/RPMS/i386/kdeadmin-3.5.1-0.1.fc4.i386.rpm  

This should build and install a copy of kdeadmin with kpackage.
Kpackage needs alot of work to get it useable.
don't use remote repositaries or recursive local repositaries
still the best interface for package management, but needs a
mysql backend.
Comment 4 Petr Rockai 2006-07-17 13:51:32 EDT
That's it, unless kpackage is fixed upstream, it will remain excluded. 
There will eventually be a replacement for it in Fedora Extras.

Note You need to log in before you can comment on or make changes to this bug.