Bug 1695899 - Unplugged network device configured in kickstart results in crash.
Summary: Unplugged network device configured in kickstart results in crash.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-03 21:15 UTC by Doug Ledford
Modified: 2019-04-11 02:14 UTC (History)
7 users (show)

Fixed In Version: anaconda-30.25.5-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 02:14:13 UTC
Type: Bug


Attachments (Terms of Use)
anaconda log (4.04 KB, text/plain)
2019-04-04 14:51 UTC, Doug Ledford
no flags Details
syslog (305.57 KB, text/plain)
2019-04-04 14:56 UTC, Doug Ledford
no flags Details

Description Doug Ledford 2019-04-03 21:15:50 UTC
Description of problem:

When attempting to create a kickstart that results in a machine resilient to network changes and issues, anaconda throws a traceback.

Version-Release number of selected component (if applicable):

Fedora 30 Server Beta

How reproducible:100%

Steps to Reproduce:

Boot with command line that enables kickstart and provides two named Ethernet interfaces (the named Ethernet interfaces may not matter, but it was in my environment so I include it here):

linuxefi /vmlinuz inst.stage2=hd:UUID=9fc1593d-7c28-4bba-8763-1207a899652b
    inst.ks=hd:UUID=9fc1593d-7c28-4bba-8763-1207a899652b
    ifname=lom0:24:5e:be:22:45:6b ifname=lom1:24:5e:be:22:45:6c inst.gpt quiet

Have kickstart with these network lines:

# Network information
network  --bootproto=static --device=lom0 --ethtool="autoneg on"
    --gateway=172.31.254.254 --ip=172.31.254.253
    --nameserver=172.31.255.253,172.31.254.254 --netmask=255.255.255.0
    --noipv6 --activate
network  --bootproto=dhcp --device=lom1 --noipv6 --activate
network  --hostname=ipa-mo.xsintricity.com

Actual results:

Traceback, failure to apply network proxy to None device.  Fedora 29 works.  It fails to activate the second network device, which is OK because there is no cable plugged in at the moment, and the device is just a backup after all, but the 30 installer croaks out.

Expected results:

System should have one interface that static configures to desired value, and one interface that autoconfigures, that way if the headless system needs to be plugged into a foreign network, the network will still come up as long as you switch the Ethernet cable to the second port

Additional info:

Comment 1 Radek Vykydal 2019-04-04 08:38:55 UTC
Please attach the traceback and anaconda logs:

/tmp/anaconda-tb-*
/tmp/anaconda.log
/tmp/syslog

Thank you.

Comment 2 Radek Vykydal 2019-04-04 13:06:42 UTC
https://github.com/rhinstaller/anaconda/pull/1934

Comment 3 Radek Vykydal 2019-04-04 13:33:49 UTC
I think I was able to reproduce the issue - the cause of the crash is the unplugged device.

It would be good to see the logs though to make sure I really hit the same issue.

Comment 4 Doug Ledford 2019-04-04 14:51:01 UTC
(In reply to Radek Vykydal from comment #1)
> Please attach the traceback and anaconda logs:
> 
> /tmp/anaconda-tb-*
> /tmp/anaconda.log
> /tmp/syslog
> 
> Thank you.

I didn't see a /tmp/anaconda-tb-* log file, but the traceback itself is in the syslog.

Comment 5 Doug Ledford 2019-04-04 14:51:47 UTC
Created attachment 1551963 [details]
anaconda log

Comment 6 Doug Ledford 2019-04-04 14:56:54 UTC
Created attachment 1551965 [details]
syslog

Comment 7 Radek Vykydal 2019-04-04 15:01:27 UTC
Thank you for the logs, looking at them I can confirm we are seeing the same issue which should be fixed by the PR in comment #2.

Comment 8 Fedora Update System 2019-04-09 16:03:52 UTC
anaconda-30.25.5-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e2e3cfdb2b

Comment 9 Fedora Update System 2019-04-10 14:37:57 UTC
anaconda-30.25.5-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e2e3cfdb2b

Comment 10 Fedora Update System 2019-04-11 02:14:13 UTC
anaconda-30.25.5-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.