Bug 1695990 - Silverblue install fails in copy_resolv_conf_to_root with "No such file or directory: '/mnt/sysimage/etc/resolv.conf'"
Summary: Silverblue install fails in copy_resolv_conf_to_root with "No such file or di...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 30
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: openqa
: 1696938 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 01:38 UTC by Adam Williamson
Modified: 2019-04-11 02:14 UTC (History)
12 users (show)

Fixed In Version: anaconda-30.25.5-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-11 02:14:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2019-04-04 01:38:57 UTC
This commit:

https://github.com/rhinstaller/anaconda/commit/8bdcce8b62d54770ae175e5809a37b8ddae05bd0

seems to have broken Silverblue installs. All Rawhide Silverblue install tests since 20190323.n.1 have failed with this traceback:

16:49:57,619 CRT exception: Traceback (most recent call last):

  File "/usr/lib64/python3.7/site-packages/pyanaconda/threading.py", line 280, in run
    threading.Thread.run(self)

  File "/usr/lib64/python3.7/threading.py", line 865, in run
    self._target(*self._args, **self._kwargs)

  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation.py", line 398, in doInstall
    installation_queue.start()

  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()

  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()

  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()

  File "/usr/lib64/python3.7/site-packages/pyanaconda/installation.py", line 67, in run_task
    network.copy_resolv_conf_to_root(util.getSysroot())

  File "/usr/lib64/python3.7/site-packages/pyanaconda/network.py", line 282, in copy_resolv_conf_to_root
    shutil.copyfile(src, dst)

  File "/usr/lib64/python3.7/shutil.py", line 121, in copyfile
    with open(dst, 'wb') as fdst:

FileNotFoundError: [Errno 2] No such file or directory: '/mnt/sysimage/etc/resolv.conf'

That commit introduced this new copy_resolv_conf_to_root() . Presumably it doesn't account for a difference in Silverblue / ostree payloads.

The same commit appears to be in 30.25.4, so this will affect F30 too I believe.

Comment 1 Radek Vykydal 2019-04-04 08:03:15 UTC
https://github.com/rhinstaller/anaconda/pull/1933

Comment 2 Radek Vykydal 2019-04-08 07:26:51 UTC
*** Bug 1696938 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2019-04-09 16:03:51 UTC
anaconda-30.25.5-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e2e3cfdb2b

Comment 4 Fedora Update System 2019-04-10 14:37:56 UTC
anaconda-30.25.5-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e2e3cfdb2b

Comment 5 Fedora Update System 2019-04-11 02:14:12 UTC
anaconda-30.25.5-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.