Bug 169602 - VoIP sound input distorted
VoIP sound input distorted
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
https://sourceforge.net/projects/blue...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 01:51 EDT by Stefan Becker
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 00:15:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2005-09-30 01:51:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After upgrading to the latest kernel BT uplink, ie. sound input, gets distorted

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. Fetch bluetooth-alsa from sf.net CVS
2. Compile & install kernel module and btsco user space daemon
3. Plugin USB BT dongle and start BT service
4. Load kernel module and start btsco daemon to create connection to BT headset
5. Make a call to an echo server, e.g. with kphone
  

Actual Results:  Sound on downlink is OK
Sound recording gets distorted, i.e. the echo comes back disrupted by pauses and long delays. Sounds like it gets recorded in pieces and between each piece a fixed pause gets inserted.

Expected Results:  Sound OK on both up & downlink

Additional info:

I know bluetooth-alsa is still alpha but it worked OK on every FC4 kernel before the 2.6.13 rebase. Here is a list of all involved programs/subsystems:

  [kphone]
  [alsa-lib]
  ALSA kernel stack
  [snd-bt-sco module (provides the "sound card")]
  [btsco (bridges between snd-bt-sco.ko and BT stack)]
  [bluez-libs]
  BT kernel stack
  hci_usb module
  USB kernel stack
  uhci_hcd module
  [USB 1.1 BT dongle]
  [BT Headset]

Everything in [] is unchanged from before the kernel upgrade.
Comment 1 Dave Jones 2005-09-30 04:08:59 EDT
Please report this to the upstream maintainers of that module.
Comment 2 Stefan Becker 2005-10-07 22:28:46 EDT
Just for the fun of it I retested the new kernel with a normal USB Headset: Same
problem. So it's not related to bluetooth-alsa, it's the kernel -> REOPENED.

Based on the retest we can now narrow it down to the following subcomponents:

  [kphone]
  [alsa-lib]
  ALSA kernel stack
  [snd_usb_audio module (provides the "sound card")]
  USB kernel stack
  uhci_hcd module
  [USB 1.1 Headset]
Comment 3 Stefan Becker 2005-10-21 22:37:07 EDT
Retested with kernel-2.6.13-1.1532_FC4: Still the same problem.
Comment 4 Dave Jones 2005-11-10 17:01:48 EST
Mass update to all FC4 bugs:

An update has been released (2.6.14-1.1637_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.

Comment 5 Stefan Becker 2005-11-10 21:28:55 EST
Retested with kernel-2.6.14-1.1637_FC4: Still the same problem.
Comment 6 Stefan Becker 2005-11-13 17:37:05 EST
It maybe that only kphone is affected by this. A simple recording loop

      arecord -Dplughw:2 | aplay -Dplughw:2

doesn't have this problem. That could mean that the actual problem might be
network stack related, ie. delayed or dropped packets.
Comment 7 Stefan Becker 2005-12-01 21:48:11 EST
Retested with kernel-2.6.14-1.1644_FC4: Still the same problem.

Recompilation of kphone didn't help either, as I expected...
Comment 8 Stefan Becker 2005-12-02 23:05:17 EST
Found another VoIP/SIP application to test with: Twinkle
(http://www.twinklephone.com). It exhibits the same problem as kphone under
kernel >2.6.12.
Comment 9 Stefan Becker 2005-12-04 23:44:00 EST
In light of my test results I've updated the summary again.

I've now compiled a plain 2.6.14.3 kernel using the config from the
kernel-2.6.14-1.1644_FC4: this kernel does *not* exhibit the problem. So it must
be caused by a Fedora patch.
Comment 10 Stefan Becker 2005-12-05 00:15:56 EST
[LATER]

Argggg... Now twinkle works OK on kernel-2.6.14-1.1644_FC4. Don't ask me why. It
didn't when I first tested it and exhibited the same problem as kphone. I
shutdown the computer completely and removed the power cord, but somehow I can't
reproduce the error with twinkle anymore :-[

kphone on the other hand has the problem also on the plain 2.6.14.3 kernel with
FC4 config. So it's something the kernel does which makes kphone stumble on
sound input. Maybe kphone does something stupid which worked OK until 2.6.12...

I'll resolve the bug as WORKSFORME for now as I have a working alternative.

Note You need to log in before you can comment on or make changes to this bug.