Bug 1696085 - [upi-on-aws] ClusterName.AllowedPattern in cloudformation is blocking user to include '-' char in cluster name
Summary: [upi-on-aws] ClusterName.AllowedPattern in cloudformation is blocking user to...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 06:50 UTC by Johnny Liu
Modified: 2019-06-04 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:11 UTC

Description Johnny Liu 2019-04-04 06:50:02 UTC
Description of problem:
Several cloudformation templates for upi on aws is blocking user to use '-' in cluster name.
Such as: 
When user specify 'ClusterName' parameter to 'qe-jialiu' for https://github.com/openshift/installer/blob/master/upi/aws/cloudformation/02_cluster_infra.yaml#L6, the cloudformation creation failed due to it does not match with 'AllowedPattern'.

While in IPI install, user is allow to use 'qe-jialiu' as cluster name, they should keep insistent.

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Abhinav Dahiya 2019-04-09 16:35:41 UTC
The cloud formations serve as *examples* to setup user provisioned infrastructure. There is no expectation of it adhering to installer provisioned infrastructure standards.

Comment 2 Johnny Liu 2019-04-10 01:34:24 UTC
From customer view, user would start his/her 1st upi setup using these *examples*, why not make these *example* more thoughtful. And I think this fix is not hard, still suggest to fix it.

Comment 3 Stephen Cuppett 2019-04-10 11:06:24 UTC
https://github.com/openshift/installer/pull/1566

Comment 5 Johnny Liu 2019-04-11 05:54:07 UTC
Verified this bug with the fixed templates, and PASS.

# oc get machineset -n openshift-machine-api
NAME                                  DESIRED   CURRENT   READY   AVAILABLE   AGE
jialiu-upi2-5gwpw-worker-us-east-2a   0         0                             179m
jialiu-upi2-5gwpw-worker-us-east-2b   0         0                             179m
jialiu-upi2-5gwpw-worker-us-east-2c   0         0                             179m

Here my clustername is 'jialiu-upi2'

Comment 7 errata-xmlrpc 2019-06-04 10:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.