Bug 1696143 (CVE-2019-1798) - CVE-2019-1798 clamav: use-after-free results in improper error validation
Summary: CVE-2019-1798 clamav: use-after-free results in improper error validation
Keywords:
Status: CLOSED UPSTREAM
Alias: CVE-2019-1798
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1696145 1696146
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 08:33 UTC by Dhananjay Arunesh
Modified: 2019-09-29 15:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-10 10:53:35 UTC
Embargoed:


Attachments (Terms of Use)

Description Dhananjay Arunesh 2019-04-04 08:33:32 UTC
A use-after-free condition may occur as a result of improper error handling when scanning nested RAR archives.

Reference:
https://blog.clamav.net/2019/03/clamav-01012-and-01003-patches-have.html

Comment 1 Dhananjay Arunesh 2019-04-04 08:38:51 UTC
Created clamav tracking bugs for this issue:

Affects: fedora-all [bug 1696145]

Comment 2 Dhananjay Arunesh 2019-04-04 08:39:52 UTC
Created clamav tracking bugs for this issue:

Affects: epel-all [bug 1696146]

Comment 3 Robert Scheck 2019-04-04 22:28:16 UTC
As per https://lists.clamav.net/pipermail/clamav-announce/2019/000038.html the ClamAV 0.100.2 shipped in EPEL 6 is not affected.

Comment 4 Product Security DevOps Team 2019-06-10 10:53:35 UTC
This CVE Bugzilla entry is for community support informational purposes only as it does not affect a package in a commercially supported Red Hat product. Refer to the dependent bugs for status of those individual community products.


Note You need to log in before you can comment on or make changes to this bug.