Bug 1696168 - should replace all "clusteringress" with "ingresscontroller" to avoid confusing
Summary: should replace all "clusteringress" with "ingresscontroller" to avoid confusing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.1.0
Assignee: Dan Mace
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 09:19 UTC by Hongan Li
Modified: 2019-06-04 10:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ClusterIngress API is replaced to IngressController API that has some more improvements. Consequence: Rest of the cluster-ingress-operator code is still referencing the old "clusteringress" name. Fix: Rename clusteringress to the updated API name where ever is appropriate. Result: Less confusion and easy to follow the code.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:47:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:11 UTC

Description Hongan Li 2019-04-04 09:19:35 UTC
Description of problem:
To avoid confusing and keep consistent, we should replace all "clusteringress" with "ingresscontroller", especially those information exposed to user. 

Version-Release number of selected component (if applicable):
4.0.0-0.nightly-2019-04-03-202419

How reproducible:
100%

Steps to Reproduce:
1. cd cluster-ingress-operator/
2. grep -r -i "clusteringress" ./*
3.

Actual results:
---
./pkg/manifests/manifests.go:	OwningClusterIngressLabel = "ingress.openshift.io/clusteringress"
./pkg/operator/controller/controller_router_deployment.go:			return nil, fmt.Errorf("clusteringress %q has invalid spec.routeSelector: %v", ci.Name, err)
./pkg/operator/controller/controller.go:			return fmt.Errorf("failed to remove finalizer from clusteringress %s: %v", ingress.Name, err)
./pkg/operator/controller/controller_dns.go:		log.Info("ensured DNS record for clusteringress", "namespace", ci.Namespace, "name", ci.Name, "record", record)


Expected results:
replace "clusteringress" with "ingresscontroller"

Additional info:

Comment 1 Ravi Sankar 2019-04-09 22:23:58 UTC
Fixed by https://github.com/openshift/cluster-ingress-operator/pull/194

Comment 3 Hongan Li 2019-04-17 06:02:39 UTC
verified with 4.0.0-0.ci-2019-04-16-221411 and issue has been fixed.

Comment 6 errata-xmlrpc 2019-06-04 10:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.