Bug 1696216 - [upi-on-aws] unable to get pod log due to tls error
Summary: [upi-on-aws] unable to get pod log due to tls error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.1.0
Assignee: Abhinav Dahiya
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks: 1699293
TreeView+ depends on / blocked
 
Reported: 2019-04-04 11:06 UTC by Johnny Liu
Modified: 2019-06-04 10:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1699293 (view as bug list)
Environment:
Last Closed: 2019-06-04 10:47:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:47:11 UTC

Description Johnny Liu 2019-04-04 11:06:16 UTC
Description of problem:

Version-Release number of the following components:
4.0.0-0.nightly-2019-04-03-202419

How reproducible:
Always

Steps to Reproduce:
1. Follow https://github.com/openshift/installer/blob/master/docs/user/aws/install_upi.md, use cloudformation templates to set up upi on aws
2. After env is set up, check any pod log.
3.

Actual results:
# oc logs cluster-version-operator-666bfb9fd5-bj9zv -n openshift-cluster-version
Error from server: Get https://ip-10-0-49-186.us-east-2.compute.internal:10250/containerLogs/openshift-cluster-version/cluster-version-operator-666bfb9fd5-bj9zv/cluster-version-operator: remote error: tls: internal error

Expected results:
could get pod logs successfully.

Additional info:
workaround:
# oc get csr --no-headers|grep -i pending|awk '{print $1}' | xargs oc adm certificate approve

Comment 1 Abhinav Dahiya 2019-04-09 16:30:47 UTC
user provisioned infrastructure *requires* users to perform additional actions like approving certificates for nodes.

Comment 2 Johnny Liu 2019-04-10 01:31:18 UTC
In UPI on aws doc [1], there is no any hint to ask user to perform additional actions like approving certificates for nodes. If need user do it manually, pls add such steps in the doc.

[1]: https://github.com/openshift/installer/blob/master/docs/user/aws/install_upi.md#option-2-manually-launching-worker-instances

Comment 3 liujia 2019-04-10 08:15:41 UTC
Hit the same issue for UPI on vmware. The same workaround can resolve.

Comment 4 Abhinav Dahiya 2019-04-10 22:55:44 UTC
https://github.com/openshift/installer/pull/1594

Comment 7 Johnny Liu 2019-04-12 10:51:07 UTC
Verified this bug with 4.0.0-0.nightly-2019-04-10-182914 and following the latest doc, it succeed.

Comment 9 errata-xmlrpc 2019-06-04 10:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.