This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 169622 - Packages missing in yum check-update output
Packages missing in yum check-update output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 07:08 EDT by Kasper Dupont
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-19 16:09:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2005-09-30 07:08:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
When installing kernel update other related packages disappeared from yum check-update output

Version-Release number of selected component (if applicable):
yum-2.4.0-0.fc4

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. run yum check-update
2. install just kernel with rpm -ivh
3. run yum check-update again.


Actual Results:  
kernel-devel and kernel-doc disappeared from the listning after updating kernel.

Expected Results:  
Packages that were not updated should still show up in yum check-update output.

Additional info:
Comment 1 Seth Vidal 2005-09-30 07:49:16 EDT
you're using mirrorlist in your *.repo files in /etc/yum.repos.d right?

If so then you just got attached to a different mirror the second time, one that
wasn't as updated as the previous one.

hence the problem.

Comment 2 Jeremy Katz 2006-04-19 16:09:10 EDT
This should be better with the metadata caching stuff in later versions of yum

Note You need to log in before you can comment on or make changes to this bug.