Bug 1696264 - libratbag: FTBFS in Fedora rawhide/F30/F29 with meson-0.50.0-2
Summary: libratbag: FTBFS in Fedora rawhide/F30/F29 with meson-0.50.0-2
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libratbag
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Benjamin Tissoires
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-04-04 12:43 UTC by Jitka Plesnikova
Modified: 2019-04-09 03:30 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-09 03:30:37 UTC


Attachments (Terms of Use)

Description Jitka Plesnikova 2019-04-04 12:43:29 UTC
Description of problem:
Package libratbag fails to build from source in Fedora rawhide/F30/F29. It started failing since meson 0.50.0-2 was built for these Fedoras. 

From meson changelog
* Mon Mar 25 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.50.0-2 
- Set -Db_ndebug=true 

I checked that the tests passed with release 0.50.0-1.

The tests failed with error:

[0/1] /usr/bin/meson test --no-rebuild --print-errorlogs
1/6 data-parse-test                         OK       0.07 s 
2/6 test-context                            FAIL     0.01 s (exit status 1)
3/6 test-device                             OK       0.04 s 
4/6 test-util                               OK       0.01 s 
5/6 test-iconv-helper                       OK       0.01 s 
6/6 ratbagctl-test                          SKIP     0.17 s 

Ok:                    4
Expected Fail:         0
Fail:                  1
Unexpected Pass:       0
Skipped:               1
Timeout:               0


The output from the failed tests:

2/6 test-context                            FAIL     0.01 s (exit status 1)

--- command ---
/builddir/build/BUILD/libratbag-0.9.905/x86_64-redhat-linux-gnu/test-context
--- stdout ---
Running suite(s): context
33%: Checks: 6, Failures: 4, Errors: 0
../test/test-context.c:67:F:init:context_init_NULL:0: Early exit with return value 1
../test/test-context.c:71:F:init:context_init_bad_iface:0: Early exit with return value 0
../test/test-context.c:84:F:init:context_init_bad_iface_open:0: Early exit with return value 0
../test/test-context.c:97:F:init:context_init_bad_iface_close:0: Early exit with return value 0
-------

Full log written to /builddir/build/BUILD/libratbag-0.9.905/x86_64-redhat-linux-gnu/meson-logs/testlog.txt
FAILED: meson-test 
/usr/bin/meson test --no-rebuild --print-errorlogs
ninja: build stopped: subcommand failed.

Dependency changes from the latest successful build can be found here:
https://apps.fedoraproject.org/koschei/build/6254978

Steps to Reproduce:
koji build --scratch f31 libratbag-0.9.905-2.fc31.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/libratbag

Comment 1 Peter Hutterer 2019-04-05 00:11:32 UTC
> - Set -Db_ndebug=true 

whoah. that is a *massive* change affecting the whole distribution and I can't fine a bug report for it except the upstream one which is fairly low on details. this is going to break a bunch of things that relied on assert() to work in Fedora. CC-ing Igor for this bug for some comments if he has anything to add here.

The FTBS is a bug in libratbag, we should enclose these tests with #ifndef NDEBUG since they rely on assert() but I'm rather happy that this triggered because it'll have quite some implications for some of my other packages too.

Comment 2 Peter Hutterer 2019-04-09 03:30:37 UTC
Closing, the meson change has been reverted in fedora now, so the scratch build passes again.


Note You need to log in before you can comment on or make changes to this bug.